Mac Steam Client - GSB launch-crash-loop


#1

When attempting to launch GSB (just updated to the latest patch today) on my Mac Steam client, the following happens:

Steam tells me it’s preparing to launch GSB.
GSB Icon bounces in dock.
GSB Icon fades from dock.
Steam tells me it’s preparing to launch GSB.
Lather.
Rinse.
Repeat.

This goes on until I can nail down the “cancel” button on the steam window, at which point everything returns to normal.

This has been going on since I purchased GSB on February 11.

I purchased the GSB bundle with The Swarm, The Order, and The Tribe, in the event that has anything to do with it. I’ve verified all my files as being positive integrity (via Verify File Integrity), and all appears to be normal. I did contact Steam Support in case it was a problem with their launcher, but they have referred me to Positech.

Help?


#2

Hi, we did the Mac version of the game – we’re not sure what the issue with Steam might be, but if you’ll email us at support at redmarblegames dot com, we can send you the non-Steam version. If you have a receipt or something that would be helpful.


#3

I’ll do that.

I admit, I’m a bit concerned about the crash-launch loop going on here. I’m interested to find out why it’s happening - it would seem to be the Steam launcher (in that the game never gets beyond initial launch state), but their support staff seems confident it’s not a Steam issue.

I’ll mail support at Red Marble right now with the purchase confirmation mail from Valve/Steam.


#4

I’m getting this as well, and have mailed RedMarble.

EDIT: uninstalling and reinstalling didn’t help.


#5

I have the steam version, and am getting the same problem. I moved it out of the steam folder, and it still crashes. I’ve emailed redmarble as well, and included the crash report. (fingers crossed)


#6

Well, this kind of sucks - it’s been a few days and not even a reply from RedMarble that they got my mail. Sending another one right now.


#7

Well, found a solution. I blew away the ~/Library/Preferences/GratuitousSpaceBattles/ directory, and reinstalled. Presto, it worked. Kind of a extreme measure, but hopefully it will help ya’ll troubleshoot it.


#8

Tried this, it didn’t work. A copy of GSB that I obtained from Red Marble directly still works normally, however.


#9

I´ve bought the Game @ Steam and now I can´t play it!!!
I click on “Play” - A window comes up which say “Preparing to launch Gratuitous Space Battles” - Then the window disappears… and nothing happens!!

I want my Money back!!!


#10

Is the need for instant gratification so high in people that they’d rather have their money back than a solution to the problem?


#11

I was wondering the same thing myself.

Given that there are more users than merely myself reporting an issue with the Steam client, I’d say it’s safe to say that neither Positech nor Red Marble are the culprits, here.

Red Marble folks - have you considered pushing this back to Valve at all? The issue would clearly appear to be with the Steam Client/Launcher, and not in the GSB application itself.


#12

It´s pretty simple: I´m not going to sell a Game when it doesn´t work!
Every Software has Bugs - of course I´m knowing this… But this Game will not start!
This isn´t a Bug - This is a problem and especially a problem which I can test before I´m going to sell it!

I´m buying Games on Steam because I want to play it instantly and not to wait of a patch - This is EA-like…


#13

Does the steam version of GSB require steam to launch? Will it launch steam when you launch it directly using the GSB executable in the game’s folder? If the problem’s with steam, and (though highly unlikely) running the game’s exe directly NOT through steam doesn’t launch steam itself…


#14

Now here’s something interesting.

Attempting to launch it via /Users/(My Home Directory)/Applications/Gratuitous Space Battles does the following:

1 - Launches Steam
2 - Launches the App
3 - GSB plays beautifully.

Launching it via Steam directly is now a 50/50 chance of it either looping, or launching normally.

That’s… more than a little freaky.