MOD for "unused" research items?


#1

Has anyone tried a MOD for the “unused” items listed in the strings.en?

People have noted that things like “research_suppress_press”, “research_university_trials”, “research_clinical_research_organisations”, and “research_gagging_clauses” are in the file. what happens if one is added to the research tree?

Just wondering if maybe the graphics or other info is buried in the code somewhere.

similar for “// Not used currently” victory conditions. At least one (“cannotCauseSideEffects”) appears to be used.

For example, a Scenario that uses:
“spendTotal”,“text”:“Spend a total of &$>{0} on factory equipment.”


#2

I tried adding “research_suppress_press” to the research tree and it failed. It is a bug in a way b/c it hung when loading the MOD and I had to kill BP (or at least, not very robust MOD loader - it should revert to non_MOD’d like it does in other “invalid” MOD situations).

I may have failed to modify research.data correctly

MOD had 3 files: strings-en.data, modinfo.data, and research.data. Loads fine w/ just the 1st 2 files. Chokes when research.data (modified) is included.

relevant portion of output_log.txt. looks like it fails on the “research_suppress_press” part.

Loading mod: C:/—/Documents/My Games/Big Pharma/Mods/UnusedResearch1/

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Start loading save game

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

SaveGameException: Error loading save game: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

at System.Collections.Generic.Dictionary`2[System.String,ResearchSpec].get_Item (System.String key) [0x00000] in :0

at ResearchProgress.GetResearchSpec () [0x00000] in :0

at ResearchData.Init (System.String player) [0x00000] in :0

at CompanyData.Init () [0x00000] in :0

at GameState.Load (.SaveGame saveGame) [0x00000] in :0
at GameState.Load (.SaveGame saveGame) [0x00000] in :0

at Backbone.CreateGameScene (.SaveGame saveGame) [0x00000] in :0

at Backbone.CreateMainMenu () [0x00000] in :0

at Backbone+c__Iterator4.MoveNext () [0x00000] in :0


#3

Maybe these research names are protected because they are/was intended to be used on the official version of the game, so the game itself prevents loading mods which uses those names and avoid people to create mods using these names. (hmm… weird hypotesis, I think…)

I’ll give them a try tomorrow on a mod I’ve created recently modifying the research tree structure.


#4

Maybe… I think someone posted getting MOD to work with unknown/undefined research (maybe it was machine or ingredient??) and a Question Mark placeholder showed instead.


#5

Yes, it was Tim. I checked it out again and it works like he said. I’m performing some scenario-testing and I’ll be releasing a mod wich modifies the research tree, including new researchs. It will even modify AI’s so they fit the new structure and research projects.

Also, I was wrong on my thoughts. I was able to create these researchs and include them on the research tree. Cannot say the same about including ther originally porpoused effects, since they are not implemented in the game, or if they exist, I don’t know how to unlock them through research tree or if they will actually work.



#6

Nice! looks like you got it to work.

There are 2 ways I know of to unlock an item in the research tree. Let us call it “research_X”.

  1. include it in a scenario in scenarios.data that unlocks it in the beginning:
    “startingResearch”:[“research_X”]

  2. connect it to another item that is (or can be) unlocked in the research.data file, via a “connect to” and a “connect from”.
    e.g. connecting it from dissolver, dissolver could have
    “connections”:[{“id”:“research_X”,“start”:“top”,“end”:“bottom”}]
    and “research_X” would have:
    “connections”:[ {“id”:“research_dissolver”,“start”:“bottom”,“end”:“top”,“receive”:true},]

If you’d like to see full example files you can look at my belt-machine MODs. All 3 of those MODs moved the incinerator/analyzer (which was modified) down near the start (“research_start”) - I think I put it next to the dissolver.
Or the “linear_hell” MOD - which moved every single research item and every single connection.

Would like to see the research.data for the image you posted.


#7

Thanks for the reply and tips, but I was not referring to connecting them to the research tree and being able to research and unlock them (or unlocking them at beggining). I was refering to unlock what they are suposed to unlock (clinical trials and all that stuff).

Here you have a copy.


#8

Thanks. I unlocked them. Didn’t do anything, but nice looking images :slight_smile: