Modding NOW POSSIBLE (just a few questions :) )


#1

Hey,

if I try to upload my Mod to the Steam Workshop and I want to select a File, the whole Window gets closed and nothing gets selected


#2

Hi, can you give me more details… I really want to fix this. I’ve been stupidly busy and apologies for not replying before :frowning:


#3

Hi,
no problem.

The way I try to create a new Mod:

  • Starting Production Line from Steam
  • Clicking the Menu Item “Mods”
  • “Submit Workshop Mod”
  • enter an Autor, a Title and a Description
  • Clicking the Button “Browse” behind the “Path” field
  • A Window called “Select Mod Folder” opens BUT the “Mods” Window has closed
  • It’s got my create mod in it so I select this Mod by clicking on it and pressing the “Select” button
  • And now I’m in the Main Menu, if I now go back to “Mods” and “Submit Workshop Mod” it’s empty again

Hope this helps you.
If you need mor information, just tell me and I’ll provide you with.


#4

Hi in my case I can’t even instal Cliffs mod. I am subscribed to it but nothing happens.


#5

I have obviously screwed something up…I’ll check all the settings.


#6

Could you give it another try and let me know if its fixed now?


#7

Hi Cliffski,

if it can help you, i have the same issue. i thinked that is there:

I have 2 differents users. The game start with my user and don’t see your mod. (I’m on W7).

Thanks for your help.


#8

I’m sorry to tell you but unfortunately your update hasn’t fixed it.


#9

I only have one User on my Windows 10 PC


#10

This is very helpful. I am working on fixes for this now, thanks.


#11

Hi all, Hi Cliffski,

I don’t know if it’s normal but when I have dowloaded your testmod (testmod.pak), I find it well, in “_unpack” directory in my user (Krys).

When I open this file with notepad++, I see the path where will go the files.


#12

Hey Cliffski,

now I’m able to create a Mod and Upload it to the Steam workshop.
But here’s my next problem.
The names of in my case marketing stuff wont show up as defined. Did I do something wrong?


#13

Hi, you just missed off the _GUINAME at the end of the translated text for the marketing name :smiley:


#14

Thanks a Lot. That fixed it for me.
Aaaand the next problem:
The Images won’t show up.
I defined the like this:

Icon = icon_marketing_flyer.png

and saves the Images at:
L:\Users\DaNeubi\Documents\My Games\productionline\mods\GlobalMarket\data\bitmaps\gui\icon_marketing_flyer.png


Neither

Icon = /icon_marketing_flyer.png
Icon = bitmaps/gui/icon_marketing_flyer.png
Icon = /bitmaps/gui/icon_marketing_flyer.png

have worked for me.


#15

Looks like this is my fault (subdirectories not supported yet on mod bitmaps folders). I’ll fix it now


#16

Thank you so much.


#17

Thanks for your Update. But unfortunately the Game won’t start now. (16:39 CET)


#18

We just pushed an update. I tested the game here and it seems ok. Are you logged into steam? what error are you getting and how far does the game get?

edit: it was my fault… fixed now :smiley:


#19

Just wanted to reply :smiley:
Thanks again :slight_smile:


#20

Another Bug I wanted to tell you:

I just released my Mod “Global Marketing”
No problems so far.

But if I want to change the Image form the Game while Updating the Mod, I get the following error and Productionline crashes:

The new Image is called “global_marketing.jpg” and the old one is also a .jpg and in the same folder