Multiple Problems :-(


#1

All,

I am unable to play GSB due to the fun “Unable to Initialize 3D Engine” errors. After trying to restart, change the prefs.ini, and, finally uninstall the game (I’m on 1.47), I ran into yet another error:

This error shows for the main game as well as all expansions.

Any suggestions? I’m really at a loss here!


#2

I haven’t seen that before, but you can just delete the folder and the \my documents\my games\gratuitous space battles folder. That’s the same as running the uninstaller.


#3

I was afraid you’d say that. I’ve deleted the folder as an experiment, but the problems still persist.

Any suggestions?

EDIT: OOOOOOOH…you mean deleting the Program Files folder as well as the My Games\GSB folder?


#4

I tried deleting the Program Files folder, the My Games folder, then re-downloading the GSBInstaller.exe from my original download link. Here is what I got in the Debug:


#5

wow, thats a pretty catatstrophic failure there. What video card do you have? and how does it run other games?
I geuss it could be shaders that aren’t working, but you should still see the main menu screen fine in that case. How far does it get?

actually, failing to get device caps is pretty much a total wipeout. Ar you sure your video card drivers are properly installed?


#6

As far as I know, they’re installed correctly. I mean, I was playing up to v1.47 with no problems, though I did have to scale things back a little bit because the card on my laptop is integrated (Intel Mobile GM965 Express).

I’ll update the driver and try again.


#7

Dear God, I’m an idiot…

I forgot that I’d turned off hardware acceleration a week ago on the graphics card. Turned it back to full and what do you know?

IT LIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIVES :smiley:

…though now I wish I hadn’t deleted the entire game…off to reinstalling everything