Neural error


#1

So after I got that starting problem fixed, there is also another error, this time, it has something to do with the neural code. After I corrected some misspellings on notepad files for mods, I tried to start the game but it says that there is an invalid neural function. I am not well experienced in code at all but I have tried to create a mod so can someone tell me what is the cause of this problem?


#2

If it’s “Invalid Neural Function:.\src\SIM_NeuralEffect.cpp 128”

Then follow this solution:
viewtopic.php?f=38&t=9054


#3

The error is back but it only happens when I try to play as the US.


#4

DO you have any mods installed? If yes, which ones?


#5

I do not have any new mods installed, just the updated version of the “Ultimate Game Balance” mod. I do have a lot of country and policy mods but they do not really affect the gameplay. One example is of the “DES” pack.


#6

Policies mod do affect gameplay. :wink:


#7

Well, they do but other than some policy mods and some country mods, I do not have any new mods installed. I really do not know what is causing this error this time.


#8

Try to disable your mods one by one (go to your mod options and click on “disable”). You should be able to find out which mod causes problems.


#9

You definitely need to disable all mods to ensure it isn’t mod related, and then start a NEW save game. The existence of mods within a save game is persistent, so if you start a game with mod ‘A’ installed, you need to always have that mod installed when running it. Sadly this doesn’t happen automatically :frowning:


#10

From what I was testing, country mods do not cause this error and policy mods like, “Sex Education” and the “DES pack” do not cause this error either. The “Ultimate Game Balance” mod and “Department of Education and Families” (paraphrasing that last mod). So the error might be mod related.

Edit: “Motorsport Policies” mod also contributes to this error.
Edit #2: “Policies pack” and “Resurrection Biology” also contribute to this error. In total, 5 mods contributed to this error
Edit #3: Error is fixed for now.