New graphic effects not showing


#1

Just noticed this particular lack - I have not been seeing the nifty new distortion effects that are supposed to be part of 1.60. No visual effect on shield hits, no ripply shockwave when ships explode. The only options I have turned off are the ship comms, camera shake and motion blur effects. Is there a particular option that needs to be on to enable the new effects? (I would have thought it would be part of “Distortion FX” but I do have that turned on.)

Little help would be nice.


#2

That’s very peculiar, Ace. The “Distortion FX” checkbox should be the only thing required to activate the new shield-impact and ship-explosion visuals. On my computer, that’s certainly all I needed to change in order to enjoy patch 1.60’s new FX.


#3

Honestly now that I looked I don’t have the new visuals. It just never was something I went for and tend to play the game in 4X.

Berny
Tried a Sinus Flush.


#4

I have the same problem…

The fact is that NONE of the 1.60 features went online on my modding station (exept for the new missile warhead limit, wich proves that my GSB is upgraded, but with problems)


#5

I’m still having this problem. It’s not game breaking just annoying that my check sum says 1.60 and I’m not seeing the new graphic effects.

I’ve tried installing everything from scratch with no luck.

Gamersgate version btw.


#6

Just to make a better description of my problem:

None of the new features (graphical and direct control ones) work, the only one that works is the max decoys limit. I’ve re-installed GSB with all of its patchs and DLCs without success, these features still not working.
Tried installing GSB in other PCs, and the v1.60 features still not working.
Also tried deleting “up” and all the patches, just to force to the auto updater to download the patch again, didnt worked.
And my PC is powerful enough to handle the update… soo…

Halp? Cliff?


#7

Just checking, the setting is turned on in options, right?


#8

Yes… ¬¬’


#9

Hello!
Are you all people who bought through gamersgate?
I’m wondering if their version is ok.

if not…well the shaders and distortion settings are the ones that control these effects. There are also some extra textures required to do them. Check that this file exists:

\gratuitous space battles\data\bitmaps\fx\shockwave_distort2.dds
\gratuitous space battles\data\bitmaps\fx\shockwave_distort.dds

Assuming they are there, ensure that the game is saving the distortion setting right. It’s in \my documents\my games\gratuitousspacebattles\config.txt

DISTORTION = 1.00
SHADERS = 1.00

If that is all ok, then ensure you aren’t getting any errors due to a lack of shader support or video card memory showing up either in

\my documents\my games\gratuitousspacebattles\debug\debug.txt
\my documents\my games\gratuitousspacebattles\debug\drawdebug.txt
\my documents\my games\gratuitousspacebattles\debug\errors.txt

Can’t think of anything else.


#10

They exist.

These are there too.

The only error I get is in the debug\error text -

28/11/2012 - 14::51 - Assertion failure:filename:…\src\SIM_ShipHull.cpp,linenum:175,build:Full 1.60
28/11/2012 - 14::51 - Untranslated HRESULT
28/11/2012 - 14::51 - D3DXCreateEffectFromFile failed
28/11/2012 - 14::51 - Untranslated HRESULT
28/11/2012 - 14::51 - D3DXCreateEffectFromFile failed

For what it’s worth, I have Gratutious Tank Battles installed on the same machine as GSB and GTB runs without any problems.


#11

Ahahaha, the shader isn’t being loaded. lets check that there. Is this file present?

\program files\gratuitous space battles\data\shaders\distortion.fx


#12

No.


#13

eeeek. If you do a complete re-install, rather than a patch, that will fix it. I must have screwed up the last patch… eeek. or just save this file in the shaders folder

positech.co.uk/gratuitousspa … tortion.fx


#14

Will check has fast as i get home ^^


#15

All of this is sounding familiar, including WayofEnoch’s error messages (my error file is constantly full of those). I will have to check when I get back to my GSB machine.


#16

Well I don’t have the

But only realized it after adding the afore mentioned fixto WayofEnoch

which without the files has made for some gratuitous hilarity.

I assume to get those files I need to do a complete reinstall?
Berny


#17

#18

Eureka! Now my gratuitousness is much more gratuitous.

(By the way, I didn’t do the full install, just added the file that Cliff provided in his earlier post. So it works that way too.)


#19

Ditto that, now i can enjoy the graphical enhancements ^^
In a non-related comment, Direct Control stills crashing my game, any news about fixes or future updates on that cliff?


#20

Do you have a way to 100% reliably reproduce the crash? I can’t easily fix any direct control crashes until i can replicate them on my PC.