New HIB version doesn't work for me at all.


#1

The old one sort of worked (well enough that I could play - challenges and deleting ships would make it segfault but I could enjoy most of the game), but I downloaded the latest revision from the website, hoping to fix these problems, and it does not work at all. It starts up and the screen is black after briefly showing the startup screen. The music plays but I have to kill the process from the console because there’s no visible or working buttons.

Where do the saved games and progress live? The windows version seems to work under WINE except that it has no sound.


#2

I just figured out that the new version and the old version are sharing a common set of configuration files. I will move the old version’s configuration files (~/.positech/GSB/) to some other location and see if the new version works.

Edit: Okay, that seems to have done the trick, now I just need to figure out what I can move back without breaking it. Hopefully I won’t have to go through the whole singleplayer again.

Edit: Moving ul.ini moved all the unlocks. I was also able to copy over my single player campaign progress. I had too many useless ship designs as it is, so I didn’t bother copying ship designs.

Edit: OH, GREAT, now it behaves exactly as the old version did and crashes when I try to load a challenge. Sigh. I should have checked to see if it did this before I copied the user data.


#3

Most likely it is a setting in the prefs.ini that is causing your issue (e.g. video resolution).

And lucky for you I have a NEW build that I’m finishing off some final testing on :smiley: And this one should be much more robust and will properly generate a crash log and tell you where it is should the unfortunate happen.


#4

Thanks, glad to hear a new version is being worked on, because I just tried moving ~/.positech again, and trying a completely fresh install from the current version’s tarball, and it still segfaults when I hit “details” on a challenge game.

This would appear to be a separate problem from the video problem I was having. I don’t know what was going on with that now…