New patch available (1.23)


#141

Yo this isent really about the patch but i have a problem. Do you guys accept vanilla visa gift cards? Cause i tried ordering democracy 2, 3 times already. I called the service for customer support twice but they never answered, only 6 pm eastern time. What i have noticed is that bunch of companies on the internet dont really accept gift cards which depresses me. I mean it is a visa and i have 25 dollars on my account just checked. So what the problem?
O yo Ciif i read you little report on why people pirate your games. Honestly this is a perfect example. I may be tempted to pirate your game some where because my legit visa card is being declined. And i called the card company and it says it fine. But fort some strange reason the only online store that accepted my gift cards so far is Steam. So while you say you cant put your game onto steam, do the next best thing for some peeps. Accept debit cards like visa.
My cousins suck at finding me gifts so we just give each other gift cards at Christmas. I know it seems weird but i really only use these debit cards online.
One last thing do you have offices in the U.S that accept this card?


#142

o one last thing i bought the original democracy 1 a year ago. I changed computers. Is there any way i can get it back?


#143

I spoke to BMT today and they do accept gift cards, if you phone them today they will sort out what’s wrong. You certainly don’t need to pirate the game. Even if we refused to accept gift cards, that’s still not an excuse to pirate the game. We take a huge list of different payment methods, and use two different payment provders just in case people ahve problems with one of them.
Hopefully you have spoken to them and sorted it out now.


#144

Hi, cliff!

I’m also stuck at v1.21. Can’t update directly to 1.23 because the last patch requires v1.22 and apparently there’s no patch for 1.21 -> 1.22, you know.

Also, when trying to redownload full version from BMTmicro got “File Download Error” because of “The password has expired” (purchased on dec 2007). What’s wrong with a v1.21 to v1.22 readily available here? Any advice, please?

Thanks in advance,

Jesus A. Mora


#145

yea, I’m having exactly the same problem. Only I’m still @ an 1.171 version of the game.


#146

Don’t worry about it (:
Exactly what details do you need? Like an order-placement code or something?
My cousin bought the game for me, as a Christmas present, but I’m sure I’ll still be able to get whatever info is needed.

EDIT: Also, should I e-mail you the info to cliff AT positech DOT co DOT uk ?


#147

Sorry to double-post.

Actually, I got my 1.18 game patched up to 1.21 with your 1.18-1.21 patch.
But you still havn’t provided any 1.21-1.23 patch yet.
I know that you recommend just redownloading the whole game. That, though is not necessarily the most feasible option, and even for some, just not possible.
Me and a few others seem to have expired download links.
I know it may cost you a few hours of work, but it would really help out alot of us, and alot of people in the future, if you could provide a 1.21-1.22 or 1.21-1.23 patch.
I know it would be greatly appreciated. (:


#148

Hi, Cliffski!

Gamersgate download is STILL giving me 1.21, not 1.23!

Sorry to be a pain!

Joe


#149

What happens if we dont have the Download link anymore? I bought the Obama edition but i dont think i saved it, didnt think we’d need it again. Im use to just downloading patches to update my games, not downloading entire new versions all the time.


#150

you can just email cliff@positech.co.uk, and I can sort it out.


#151

FYI found a glitch.

The symbol for tobacco laws under law and order is the same as science funding.


#152

Solved! Emailed to Cliff and got a prompt response - a new link from BMT. Now enjoying latest v1.23

Thank you, Cliff.


#153

Hi
I try to patch like every time before, by downloading the actual version from download link provided to me when I bought the game. But now I can’t download and get this message
"File Download Error, The password has expired "


#154

Hi, just email me with your contact details. The download links expire after a year as I recall, but I can reactivate them.


#155

This seems to be happening to my download password too.
According to the original email my password should not expire until August 14th.
I emailed btmicro and am awaiting a response.


#156

Well, I just emailed support at gamersgate and they’ve updated their download to 1.23 (was previously only able to get 1.21). Enjoying an up to date version now, and I encourage other gamersgate customers to try downloading a new version if they’re still playing with 1.21 as it’s probably fixed for them too (but I can’t confirm this).

Only took a couple days to sort out, it wasn’t hard.

Happy playing!
Tssha


#157

I just purchased the “Best of Indie Bundle” from D2D UK, and I’ve enjoyed Democracy 2 very much. Checking this forum I’ve found about this 1.23 patch. The version D2D is offering is 1.21, so I had to download the patch from another site (I noticed later that there’s already a download link on this thread). But, after applying the patch a weird thing is happening.

When I try to Update through the “On-line” button I get this message: “An updated version of the game is available. Re-use your download link to get the new installer”. I guess you mean the download link for purchases made through your site, so I’m out of luck here.

My question is then, how can I get that “new installer”? Is there any way to get the most updated version from D2D?

Thanks in advance and kudos for a great game.


#158

Hi, I’ll make sure D2D get given the latest version, and you can then update it from them,
Cheers


#159

I have the same issue as Kenoxite. I clicked the update button after first launch and it did download and install some files. Yet when I restarted the game it still shows up as 1.21 Full. I’ll keep my eyes peeled on the D2D UK site in the hope of the patch arriving.


#160

I’ve emailed D2D the latest version, maybe the guy I speak to isn’t there at weekends but they should be on the case soon.
as i recall its mainly bug fixes between the two versions, not any big features.