New unit names get mangled


#1

I’m not sure if this is just me, but When I create a new unit, say “Heavy Armored Long Range Beam Cannon”, and save it, it becomes “heavy_armored_long_range_beam_cannon”.

To workaround this, I open my unit files directly and correct the issue, but it is kind of a pain.

Using Win7x64, with latest GTB.


#2

That should only be the filename though, the name shown in the game is a different string of characters entirely, or is that not working for you?


#3

The names show up mangled in-game too…

I had this behavior in Beta, and thought it would go away when I got the final release (which I only got to doing until now), but the problem persisted.

That said, I do have a few other issues, such as medals resetting on every start etc…

It would appear I am the only one having this issue? I’ll just do a complete reinstall, and see if it persists.


#4

Definitely do that. You need version 1.012. I just tested it again and its working fine, so it sounds like somehow you have a corrupted or old copy.


#5

Thanks a lot for the support Cliff. The names show up correctly now. The file names are still lower case + underscore, but this is normal I believe.
Why is it that way though? Sounds like you’d have to go out of your way to change the file name though no?

As for the medals: I still get “Complete 1 Battle” every time I start a new game. Medals are saved inside my “medal_database” directory? Because mine stays empty…


#6

Are you logged in with an online profile? I’ll investigate the medals stuff…

The filename stuff is to keep filenames usable by the operating system. This means that some characters are supported in names which you cannot use in filenames.


#7

Was I supposed to login for the medals? If yes, I apologize, I wanted to get a better hand of the game before going online.

So no, I did not register nor go online yet. Is it a pre-requisite to saving medals?
PS: I have the PC version from Positech.


#8

It should save them anyway, but if it isn’t, having an online connection will ensure it definitely does.


#9

Thanks! It worked.

My install must be a mess :confused: After logging on, it prompted to Update my game, which it did. In the mean time, I re-installed the game again, and now, the game won’t upgrade anymore (in the sense that it doesn’t give me the pop-up prompting me to). I’m stuck @ 1.012. Is there any way to force a manual upgrade, or to find an up-to-date installer?

The installer that came with my positech purchase (or should I say, the installer pointed by the link in the email) is 1.012.


#10

the game only does an update check once a day (assuming you have entered a username an serial code) unless you delete the lstchk.ini file in \mydocuments\my games\gratuitous tank battles, so don’t worry, it will update.