No online play and profile save with Mac App Store?


#1

I tried the demo of GTB from Red Marble, then because I had an Apple gift card I purchased the full game through the Mac App Store. I have run into a few problems though:

  1. When I go to Online maps, the list is always empty
  2. After I have won a medal, if I go to my profile, it’s there, but if I quit and restart, all my medals are gone
  3. In El Alamein I get the HUD, but the map shows as blue and white “snow”, like static. The other maps play fine.

Also, I’ve deleted the Demo, and in case it made any difference ~/Library/Containers/com.redmarble.Gratuitous-Tank-Battles-Demo. No luck.

GTB Version 1.017.3 for Mac
Running on a 2009 MacBook Pro with NVIDIA GeForce 9400M graphics and 8GB RAM
Mac OX 10.9 “Mavericks”

Anyone got any ideas?


#2

Strange - At this point in time I cant think of any solutions.

Quick question: have you registered online ?


#3

How do you register?
I can’t find anything in the manual or on the GTB website about registering.
Just instructions to enter your serial number (which I don’t have due to buying it through the Mac App Store), pick a user and commander name and you’re good to go.


#4

I do not know how much this differers with Red Marble Games.
When I bought the game from Positech, i was issued a link and a code XXXX-XXXX-XXXX-X for online registration.

When you open the game you head to the profile/online setup and register there.


#5

Yes, I’ve done that, apart from the Serial number, as I never got one.

Maybe it’s time for the nuclear option and wipe all traces of it from my system and re-install from scratch. I’m assuming it’s some interaction with the Demo from Red Marble and the Full version from the App Store. The fun of multiple versions for multiple distribution networks… :frowning:

What should I back up to save my efforts so far? I figure the following are a good start, anything else I should grab while I’m there?
player_units
unl.dat
tutorial_seen.ini

The above should save everything except campaign map progress, but I don’t mind having to fight through the maps again, I mainly don’t want to lose my unlocks. In fact fighting through them all again should help me unlock a few more. :slight_smile:

Also, thanks for all your help so far Darkstar.


#6

Good idea, I have read that people have had issue when installing the full game over the demo. So give that a shot.
As a better suggestion - copt the GratuitousTankBattles folder and then uninstall the game. (follow up with a tactical nuke if need be)

Then reinstall the game and copy across those files you have identified. In case there are a few others, you can drag them across as well from the copy you made earlier.

In the meanwhile - I have requested for some Heavy Artillery to help resolve the issue :slight_smile:


#7

Sorry for the confusion about this. When you buy the game at the Mac App Store, it’s supposed to generate a serial number for you automatically. In some cases this seems not to be happening. If you didn’t get a serial number, email your Mac App Store receipt to support at redmarblegames dot com and we’ll send you one you can enter manually.


#8

Ah, that would explain it. I just sent a very detailed email to support about this. I guess you can ignore that now. I have also now sent my iTunes receipt too.

Would the serial code also explain the Blue/White snow I’m seeing instead of a map on El Alamein? Or do you think that is more likely a shader issue? Should I start turning off effects? Considering the locale, I’m thinking sand clouds to be a likely suspect.

Thanks Darkstar and RedMarble, looking forward to my Serial Code…:slight_smile:


#9

I have received my Serial Code, yay!

Online works now.

I’m still getting the Blue/White snow on El Alamein, I’ve tried every effect option and graphics level and the only one that makes the snow go away is turning off “Distortion Effect”, which I’d hazard a guess as Heat Haze?

I can play the game quite happily with that option disabled, but if there is any information that I can gather for you as to why it doesn’t work on my machine, then ask away.

Cheers! :smiley:


#10

At the moment the only thing i can think of is drivers - update your drivers to if that resolves the issue.
(Did it happen with the demo ?)


#11

It’s a Mac, so I’m stuck with whatever Apple wants me to have for drivers, that said, I’m on the latest from Apple and they’re usually not too far out of date (I’m on Nvidia v.310.40 vs latest Linux on v.319.60 and latest Windows on v.331.65).

The Demo doesn’t include El Alamein, so I didn’t get that far.

As I said, having never seen the Distortion effect, I don’t miss it and I’m still enjoying the game. If there’s any further details I can give the developers to help them get it working for others then great, but I’m good just being able to play the game! :slight_smile: