No screen resolution options


#1

Hello,

I bought Democracy 3 (and both expansions) about a week or so ago. After some system changes, the game resolution options are gone.

I’m running Ubuntu 14.04LTS, on a Dell laptop (7537) and changed from the integrated Intel graphic chip, which was causing a rather annoying flashing windows issue with Democracy 3, to the NVidia GT 750M. (changing it is beyond the scope of this post, but a rather lengthy story)

My system does support lower resolutions than the 1920x1080 full screen, however, I prefer to play D3 in a windowed mode, and that is no longer available.

I’ve tried deleting the ~/Democracy3 folder (along with ~/.local/share/democracy3) and reinstalling, but to no avail.

Any suggestions?

BTW, the rather annoying window flashing is gone with the NVidia graphics card being used … so that’s a plus.


#2

Ok, here’s some more information concerning my system (obtained after a complete wipe of the HD for other reasons)

Upgraded to Ubuntu 14.10/64bit.

When using the “Additional Drivers” tab in the System Settings -> Software & Updates, I’m using the NVIDIA binary driver (nvidia-331). I was able to get Democracy3 working after loading several 32bit packages. I still get no extra resolution nor windowed mode options. When I switch back to the nouveau driver, those options come back. Set a windowed mode.

Switched back to nvidia-331 driver and now I get the following error:

So obviously, the driver “nvidia-331” doesn’t support something that Democracy3 is trying to do.