[non-critical] Tutorial crashes subsequent new game hard


#1

Sorry if this has already been posted. I did a quick browse through the forum without seeing it reported.

Anyways:

After running through the “How To Play”, starting a new game causes the game to crash hard, i.e. I get a “this program has performed an illegal operation and needs to close” window.

Minimal reproduction steps:

  • Start Democracy 2
  • Click How To Play
  • “Click to continue” after loading
  • Hit Escape
  • Start new game
  • Select “Malaganga”
  • Game crashes 2/3 through loading

This is the shortest route to crash; running through the full tutorial instead of “escaping” out at the start causes the same problems.

Not a critical bug for me, as it works fine when I restart the game.


#2

Hi, I can’t reproduce this (just tried). Is this in the latest version (1.19)? Is there an error message written at the end of debug.txt inside the games ‘debugdata’ folder? Can anyone else reproduce this?
Cheers,


#3

Just noticed that Impulse gave me version “Full 1.18”, and says there aren’t any updates. So, no, I haven’t got the 1.19 version.

There doesn’t appear to exist any “debugdata” folder along with the others under “Program Files\Positech Games\Democracy 2”.

I should check this again with 1.19. Will it be on Impulse soon?

Tried going for “On-line->Update” via the in-game menu, which appears to be the same menu I used for activating the game on sunday, but it claims “Error - Order ID invalid”. :frowning:


#4

Thats fixed now, the server move screwed up the id stuff but its fine now. Impulse have the new version, sounds like they haven’t updated it yet.


#5

Glad to hear it’s fixed.

I’m really impressed with your support on this game: Queries are answered quickly, bugs are fixed quickly, patches are released frequently. Several thumbs up! :slight_smile:

Impulse is taking their time; still no update on my 1.18. Oh well, the game is fully playable, so no rush for me.


#6

I can reproduce this…now. :frowning:

I tried adding in a few mods, and the game crashed HARD when I did that. I went back into my backup (original, no mods) data directory, and reloaded that…and the game still crashed. I uninstalled, rebooted, and reinstalled, and it still crashes when it gets to the Loading Mission portion of the game start-up sequence. This happens every time I try to run the game, regardless of which country I select.

I also purchased this game through Impulse, and there is no debugdata directory for the game. The game is installed in the C:\Program Files (x86)\Positech Games\Democracy 2 directory on my machine (using Vista Ultimate…new laptop came with it.) when using Impulse, and so far as I can tell there’s no choice to install it to a different directory. I’m somewhat puzzled by the lack of debugdata directory, though. I purchased Rock Legend through Positech, and there is a debugdata folder in there.

Impulse is still on v1.18, by the way.

I’ll keep looking around to see if there’s anything else I missed…and if there is I’ll let you know.


#7

Impulse are updating today I think, but that debugdata folder should be there. It’s a bit suspicious that it isn’t. You don’t have a non standard copy of windows in any way?


#8

Yeah, I was a bit confused about that too, since it exists in the remains of the Democracy 2 Demo folder.

I’m using a Norwegian edition of Windows XP, which means the game is installed in “H:\Programfiler\Positech\Democracy2”, but otherwise standard. There is no debug folder in the “wrong”, unlocalized install location (“H:\Program Files…”) either, and the Demo put it in the correct (“H:\Programfiler…”) location.


#9

My version of Windows is Vista Ultimate (64 bit) If it’s a pirated version, I’ll be able to get the company that sold me my laptop in lots of trouble… Impulse installs the game i a “non-standard” directory, if that’s what you mean. You don’t have a choice to install it in the default directory…it jut plops it in the “C:\Program Files (x86)\Positech Games\Democracy 2” directory for me (but on a non-64-bit windows, I assume it would just be in Program Files instead of Program Files (x86))

[Edit]

Just installed it on my old machine to test things out a bit more. This machine is WinXP Professional. Downloading Democracy 2 from Impulse once again, the game installed in the “C:\Program Files\Positech Games\Democracy 2” directory. There is no debugdata directory in either the main directory or the mods directory in the My Documents. Perhaps the lack of the debugdata directory has something to do with the install directory not being in the normal place when you use Impulse to download it? (By the way, as of 10:44 PM today, Impulse is still using v1.18)

[Edit again]

Go news - Democracy 2 works on my old machine.
Bad news - I copied over the data directory from the old machine onto my new laptop, as well as the folder that goes into the My Documents folder. I then ran the game on my Laptop, and it still crashes at the Loading MIssions screen. I looked into the data.ini file, and in the [setup] section, the first two lines are:

mission = data/missions/mission1.txt
events = data/simulation/events.csv

I looked in the data/missions directory, and there is no mission1.txt file. There is also no events.csv in the simulation directory. The last four lines in the file are:

situations = data/simulation/situations.csv
simulation = data/simulation/simulation.csv
policies = data/simulation/policies.csv
voters = data/simulation/votertypes.csv

and each of these files exists on my hard drive. Are the two missing .csv files the problem that I’m running into?


#10

No, those lines are legacy and are currently ignored. That won’t be it. I’m still investigating…


#11

Crap. I was hoping it would be something simple like that… If there’s anything that I can do to help you troubleshoot this, let me know. Here is a list of what I’ve tried to do to fix the problem. They’ve obviously all failed so far:

Uninstall and reinstall he program using Impulse (a couple of times)
After an uninstall, go into the registry and delete all of the extra Democracy keys that were still there
Copy the data directory and the Democracy2 folder that is supposed to go into My Documents from a fresh installation.

I get the same problem each time. I’m starting to think that Impulse may be part of the problem since it installs Democracy2 in a non-stanadard directory?? I wasn’t a big fan of Impulse before this…if anymore of your games are put there, I think I’ll buy them straight from you instead of going through Impulse! (Impulse still has v 1.18, by the way)

[Edit]

I downloaded the Demo and re-installed that, and that worked fine. It included the debugdata folder and the two .txt files as well. I copied the data directory from the Demo into the full version’s directory, and I still ended up with the same problem.


#12

OK…I found the debugdata.txt file. Impulse installed in the following directory:

C:\Users\sambrookjm\AppData\Local\VirtualStore\Program Files (x86)\Positech Games\Democracy 2\debugdata

Don’t ask me why…I was happy to find the darn thing!

I’ll try to upload the debugdata.txt file, so you can check it out in all of its glory. As an aside, one thing I did notice is that it detects my Laptop has having WinXP in it, rather than Vista Ultimate 64-bit. I think you had mentioned something about this in another thread somewhere.

OK…I can’t upload a file with a .txt extension. Let’s try zipping it up.
debug.zip (1.49 KB)


#13

if you email me your impulse receipt I can sort out a version from me to see if that fixes it, but I suspect not. The impulse version should not differ really.
It looks like the game can’t find ANYTHING, and I wonder if the installer has screwed up the working directory somehow, although that’s impossible for it to even vaguely start in that case. I suspect this is partly related to it detecting the O/S wrongly.
The location of the files being there is related to the cleverness Vista does when it encounters a ‘legacy’ app that tries to put data in the programs own directory, and insists it goes elsewhere. its like a virtual remapping thing. The thing is, it works fine on normal 32bit vista on my dev machine and everyone else’s.

Vista ultimate on a laptop sounds… interesting anyway.

I suspect this may be either a problem with the programs shortcut (try running it directly from the directory) or a permissions thing under vista ultimate, or possible some weird O/S level thing. If you can run the game in compatibility mode for XP it might be worth a try.

Much though I prefer people to buy my games direct, I doubt it’s actually an impulse problem.


#14

OK…this is getting weirder and weirder.

If I run it in WinXP mode, it still doesn’t work.
Running it from Impulse or the Desktop shortcut created by Impulse also causes it to crash.

If I run it as Administrator it works. (My normal account has administrative rights, so I didn’t think it would make a difference. It did.) It works as an administrator either with or without the WinXP compatibility mode.
Creating a new shortcut from the Democracy2 directory and running it from there works (assuming I run it as administrator).
Running it directly from the directory works as well (again, assuming it’s run as Admin.)

I’ll still E-Mail you the receipt, though. (Well, once the credit card info is deleted! :slight_smile: At the very least, I won’t have to waste the bandwidth from Impulse downloading the game several times again to get it working!


#15

i bet the shortcut working directory on the impulse installer is wrong.


#16

Yey! Just got 1.21 from Impulse 20 minutes ago and I can confirm the crash is gone. I also have a debugdata folder now.


#17

Hooray! I’d updated manually already, but it’s good to know that they got the update on their servers. I had problems with one of their games earlier, and the patch went up almost as soon as it was sent to Stardock. What was the response time on this one, if you don’t mind my asking?

Edit - Still get the crashing issue if I’m not running as Administrator…but the rest of the game seems to work fine.