Notes about the latest version

The problem with impulse is just that you need to correct the install folder for the patch, it should still work fine, and download the patch fine. Those patches are stored within the MyDocuments\My games\Gratuitous Space Battles\Patches folder, so you can always re-run them. it doesn’t matter if you installed the patch to the wrong folder before, just re-run it and point it at where you installed the game.

Obviously I mispoke, in a hurried rush to leave for work today. As I mentioned in my 1st post I have it from Impulse. As I mentioned from my 2nd post, I cannot get it to update.

Trying your fix now,

Ok, I found the Prog Files>Positech Games>GSB folder and I see the fmodex.dll in there. I run the 116 patch and point it to that folder, it runs, and when i tell it to run it gives me an error stating that the fmodex.dll cannot be found and it crashes. Any ideas, I have thought about just uninstalling and starting over but I am unsure of what I need to back up to save my progress and my ships.


Allright, I figured out my issue. when Impulse installed the game it seemed to install it to a folder called Gratuitous Space Battles. So I pointed the patch to that install folder. However when the patch was trying to install it wanted to make a folder called Gratuitous Space Battles Beta, thus creating a subfolder in the actual game folder. Once I deleted the Beta portion and made it match my install directory, all worked well. I also found where the ships and saves are stored apparently. Thanks for info! :smiley: Back to playing.

actually uninstalling and reinstalling will still keep all your ships and settings, but it sounds to me like you might be clicking an icon tht runs the game from the wrong place. If you right click the games icon, check its pointing to the correct location (in your case, the impulse folder)

Thanks for the help, I got it fixed and working fine now cliffski. I updated my above post to reflect what I did. The only issue now, is that in the bottom left corner of Impulse is still says v1.15b but when I run the program it is running 1.16. The game runs so that is what is most important.

I almost brought through Impulse, but where ever possible I buy from the Developer site or elsewhere. I just loath the fact you don’t get a standard installer with impulse. All those ‘game.impulse’ files that need impulse for installation… sux! I hate having to install impulse just to install a game (Like, if I do a Windows re-install)

Unless it’s specifically a Stardock game, I don’t bother with Impulse any more. Too much hassle, not enough user control of installation, a mission and a half to back a game up, and updates to games are sometimes slow to come. Slow updates are a similar problem on Steam & D2D also.

Besides, buying from the developer for this game was the same price as Impulse, I get an installer, and the Dev gets all the profit.

Sounds good to me.