OSX Crashing On Startup


#1

I got this game on the Humble Indie Bundle a while back, and I have been loving it. This kind of game is perfect for me and I truly wish there were more in this style.

Up until recently, it has been running fantastically. Unfortunately, if I try to run it through steam (which I have been doing) the game icon pops up for a fraction of a second before quitting itself. Neither verifying the file cache nor re-installing seemed to help the issue, so I decided to try and see if the direct link I had been given as part of the Indie Bundle would prove more fruitful. It got as far as the title screen before giving this error:

Ship Hull not found -> Tribe Tranquility Frigate hull:/Development/Positech/GSB/GSB/…/src Code 23rd jan 2010/ SIM_ShipHull.cpp503

It seems odd to have suddenly stopped working, as I didn’t recall seeing it patched since the last time I played, so I thought I’d post it here and see if anyone else had an issue/bring attention to a possible bug (didn’t see a similar issue in the board already). As I said though, it’s been solid as a rock until this point, and I’m not going to fret too much as it hasn’t been that long since this started happening. Still, if anyone has a solution that I haven’t tried, it would be appreciated.

EDIT: Contacted Red Marble Games. Seem to have the problem mostly worked out.


#2

Hey Jopoho,

It’s quite possible that GSB is calling for a Tribe hull (i.e. tranquility frigate) design or otherwise that isn’t there in your user created ship folder. It could also mean that steam pulls files from a different source and there may be two locations in which files are taken but the “wrong” one has the ship hull files in them.

Did redmarble fix your issue?


#3

Did you find a fix for this as i am having the same problem ?
Cheers Laird