[Outdated][Bug 1.11] Stockpile Overrides Configure Imports Settings


#1

I make my steel sheets in one part of the plant and deliver them to another part a long distance away where they will be used to make hoods, trunks and roofs. I use a dedicated Resource Conveyer to carry the sheets. I decided to use a stockpile local to where they were being used to keep the line moving fast.

To be clear, the Fit Roof, Fit Hood and Fit Trunk were all set on the Configure Imports tab to use Local Only for their respective items. The Make Roof, Make Hood and Make Trunk areas were also configured to use Local Only for Steel Sheets and the stockpile was set for 36 Steel Sheets on the conveyor feeding all of the Make Roof/Trunk/Hood areas.

This worked fine until I upgraded to a sunroof and had to connect a Resource Line from an Importer to my Fit Roof supplies. Suddenly the Steel Sheets being manufactured ceased supplying the stockpile and the Resource Importer line was backfeeding to the stockpile, which then supplied my Make Roof/Trunk/Hood areas. The Roofs/Trunks/Hoods were fine and still supplying Local Only, but the Steel Sheets were overridden and being imported.

After removing the Stockpile, everything worked fine again, but I no longer have a stockpile of Steel Sheets local to where they are being used. I have not tried this glitch with other items, but I suspect it will be the same.