[Outdated][Bug 1.15] Ressources falling trough the world


#1

After i accidently failed with my money i loaded the last autosave. My game is now glitched as hell and broken.

Ressources just falling down like waterdrops and slots says they dont have any ressources. Replacing the conveyer input things wont fix the problem. Reloading the savegame too.

I can upload the savegame if it helps.

Best regards.


#2

Hi Belion,

hard to ask but still to be sure: You use game version alpha 1.09 and it’s a savegame from the actual and not from an older game version?
Have had such behavior on 1.07 because of removed and re-placed Resource Importer …

Thanks in advance


#3

They come for our supply lines. Stop them before they escape!

Bug occurred while running attached save.

I made a mistake (bought a neighbouring plot by accident), reloaded and this bug occurred. Fixed by quitting completely and reloading said save.
p1 complete 2.xml (666 KB)


#4

modders we officially need a reskin of the game so that this looks like we are in a Star Wars ship producing X wings. just sayin


#5

Hi,

looks to be identical with [Open][Bug 1.08]Ressources falling trough the world

How to reproduce:

  1. save a running factory while on Super Speed
  2. quit to menu
  3. load the same savegame (a different one will not work)

#6

… merged threads together …


#7

Occasionally when restoring from a save game after a few hours of playing, the graphics representing the resources opt to go off the rails literally and figuratively by going to the upper corner or drifting lazily around the map in straight lines. I’ll provide a screenshot once I figure out how to do as such.

Also, I have had a few instances where less than a block away a resource is available from a site but it obstinantly refuses to path it, displaying ‘Insufficient Resources’ regardless of what I do to routing within the site and with the resource rails. Could you put a ‘reinitialize routing engine’ button in or have a timer that reinitializes it after n seconds of ‘Insufficient Resources’ errors?


#8


was the bug I was mentioning


is something I noticed while I was faffing about.


#9

Would you please take a look into this bug report?

It looks like the same but not sure if you where on Super Speed when saving the game …


#10

Yep, it is.


#11

… Merged Threads together …


#12

Hi,

I’ve created a new game in v1.14. After playing it for a while I decided to expand the factory, but my layout was horrid, (I would be nice if you just place a item it would give you the full amount back). So I loaded a previous version of the game, but after doing that I have flying components around the factory. I know I want my cars flying of the shelves, but not all the car accessories! Image attached.

Cheers,



#13

Just realized i posted it under the wrong category.

note, if i reload the same game again it didn’t happen, seems to be intermittent


#14

I did try a search but didn’t see it mentioned.

Had the game purchased for a while, but only now got chance to try it out. Had a slight issue with conveyors (could make it clearer that its one-way or autocorrects perhaps), but suddenly my stockpile showed ‘Insufficent Resources’

I tracked the route and it was connected and wasn’t being tied up delivering elsewhere… I saved and reloaded and saw this…



#15

Do you know what you did before the resources started to float?
Could it be related to this bug report?


#16

… Merged Threads together …


#17

Oooh interesting. so we think this is somehow related to save games? I cannot replicate this, which is why sadly its still being experienced. Does anyone have a 100% reliable way to trigger it?


#18

I tried to reproduce as mentioned here in 1.14 with my actual savegame but either when trying to save again (shortly after loading) the game crashes or after load, save and quit to menu the game crashes as soon as I hit the ‘Load Game’ button.
In both cases it’s ‘Failed to allocate file buffer memory:…\src\SIM_LoadGame.cpp 97’ error. At this point (before confirming the error message) the game still uses 1435 MB RAM:



And the savegame:
load_save_crash.rar (655 KB)

So same procedure with an older (and smaller) savegame and got the floating resources again …
waiting_for_1.14_superspeed.xml (263 KB)
One crash later I loaded the same (small) savegame. There were no flying resources but the vehicles at the slots are not processed anymore:



But zoomed in there is a vehicle at the ‘Fit Engine’ slot:

So what I tried to do is:

  • load a working savegame
  • switch to super speed
  • save it again
  • quit to menu
  • load the super-speed-savegame (resource should fly to somewhere)
  • save again after a short moment (while flying resources are still visible)
  • quit the game (to windows)
  • re-start the game
  • load the latest savegame and see if the resources keep flying away

But at all I don’t have a suitable savegame anymore :*(
So maybe someone else could try this …

[Edit]
Cleaned my savegame folder, wiped all the savegames (using the windows explorer) except the attached big savegame.
With just this single savegame there are no crashes, no flying resources … weird …
So, can in be related to my other bug reports (here and here)?

[2nd Edit]
Tried to reproduce the floating resources with a clean install but without success. So can in be related to the savegame-folder containing savegames from earlier game versions? No other clue at my side …


#19

Hi, all Production line users!!
I have been having a problem with my resource importers the resources fly all over the map?
I attached a video so you can see. youtu.be/ko8GBATb9Zk
Thanks


#20

Hey baboom,

would you please take a look into this thread?
Do you know what you’ve done before?
Would you please store all your savegames to save place or zip and upload them? I tried to get them flying but can’t get it anymore because of deleted files and created new savegames.

Thanks in advance!