Party membership and activists always @ zero


#1

Hi bought Democracy 3 and trying to play the game, with not much success. Each time I start a new game, party membership and activists are set at zero, which is weird since I just won an election apparently. Whatever I do, party membership does not increase and whatever I do i cant win an election. Is this a bug or what is going on here? Thanks for any replies.


#2

Same here, no idea why.


#3

Yep. Same here. Nothing happens. No increment at all which makes the game break after one election.


#4

I found out that this only happens when you tick Monarchy at the beginning of a game.


#5

Hi, the party membership may well be zero at the start, depending on the country you select. The membership will grow over time if you can get enough of the electorate to REALLY like your current policies. This is by design.
In some other maps, you may start with high party membership, depending on the current happiness of the people.

Note that the happiness of the people is dependent upon the current state of the country, assuming nothing changes. Although you just won the election, this was presumably based on improving the country. In other words, you won on the back of promises, now you have to make the promises come true.


#6

Hi there. I too am having this game breaking bug of having party membership and zero stay at 0. This happens with the monarchy ticked or not. I loaded a save where I held 100% approval for 3 consecutive elections from several months ago. Within a few turns, my activists hit 0, and then my party membership dropped to 0 shortly after. The percent of people voting for me would then stagnate at 26% and would not move. It should be noted that I repeated this with several other save games with the same results.

When I started new games, party membership and activists would stay at 0. Even if I managed to win the first election, eventually my approval would dip below 50% and I would lose the next election. All the while, party membership and activists stayed at 0.

I tried completely deleting and reinstalling the game. That did not fix it. I am running Democracy 3 with all 4 DLC and no mods. I really love playing this game, please help.


#7

I’m having the exact problem as Bluedude. However I noticed that this problem only started happening for me after Electioneering came out, but turning off Electioneering in the mods menu doesn’t help.

Anyway this glitch is very annoying and makes the game pretty much unplayable, it should be fixed.


#8

I am having this too. I reinstalled, deleted all mods and reinstalled again. It is not possible to get activists or party members.

On the Ipad everything is working on the PC version there is no change in numbers.


#9

Are you sure this is working as intended? In Democracy 3, France and Germany are the only countries where you start with any members. Nothing I do in-game seem to have any impact on that. While Germany’s numbers (below) are pretty ridiculous as well, France’s party membership is comparable to it’s opposition. In Democracy 3 Africa, none of the countries have any party members.


#10

So how did you get elected in the first place? Are we to suppose it is a government appointed after independence, or something?


#11

Hi, it could be possible to get voted in with no party members, many parties are state-funded. I admit that the game may skew a little too much to the extremes (you should always have SOME members) but in support terms, there isnt that strong a link between party membership and electoral success.


#12

They may be state-funded, but they must still have had more than 0% of the vote.


#13

Cliffski, stop ignoring your users. We’re not stupid - most people who play this game aren’t.

You are sitting there talking about governmental theory when we are saying that party members are ZERO. ABSOLUTELY ZERO. From the beginning. And nothing you do in game changes that, no matter how popular your policies are, no matter how cleverly you play the game. It is utterly game-breaking.

Fix it, don’t tell us it is “working as intended”. It clearly isn’t.


#14

we released a patch that addressed this weeks ago.


#15

Apparently the fix did not work, and at least the Steam version is still suffering from this issue.

I have all the DLCs installed and my party membership stays at 0, here’s a screenshot I took just now.

I tried, reinstalling, deleting all my settings and the problem persists.



#16

Hi, I have the same issue, even after reinstalling and purging the My Games\democracy 3 folder.
It is quite frustrating because the content is really interesting.


#17

Same issue here. I just bought it on Steam and for 3-4 quarters all is fine ~70% and suddenly I have 0 members and activists, vote probabilities of -1% and during the vote about 80% non voters.


#18

Hi is this a non-english version of the game? We are currently changing the games installer so its all in one exe file, which we think will fix this issue for everyone.


#19

I have the English version


#20

Thats very unexpected, what is the version number at the top right of the screen.
Also, is this happening for you with NEW games, or is it only something you experience from saved games from a while back? There was a bug which ‘embedded’ itself into save games, and thus can still show up in the latest version when playing old games.