Patch 1.002 feedback thread


#1

Post any new bug reports, issues or comments on the changes in patch 1.002 here. The patches roll out over 24 hours, so you should gradually all get it.

[code]version 1.002

  1. Hull weights and costs for all mobile units have been adjusted. Module costs have also been adjusted, and hull cost is now correctly included in cost calculations.
  2. Players settings for showing paths and damage numbers are now remembered between battles, and those buttons display correctly as toggles.
  3. High scores now correctly saved for multiple difficulties and attempts.
  4. Open blue battle ‘hints’ now close correctly if you quit a battle whilst one is visible.
  5. Deleting the current loaded unit from the design screen, then selecting a module or augmentation no longer causes a crash to desktop.
  6. Closing the map editing window in the middle of a tutorial no longer leaves a tutorial window hanging.
  7. Delete key now correctly deletes the enxt character in text edit boxes.
  8. Map scroll speed (when mouse is at edges) now configurable under options.
  9. Hang on resuming from alt+tab fixed.
  10. Errors relating to the wrong design being deleted when you try to delete a design from the ‘load design’ dialog are now fixed.
  11. You can now cancel a preferred target for a unit by selecting them, then right-clickign an empty area of the map (neither path nor unit).
  12. Removed some redundant unit-layer tooltips on design screen.
  13. Invalid option to fight a custom map against scenario units is now greyed out.
  14. Custom maps now have a unique ID and never inherit the high scores of their base map, even if not re-named.
  15. Debug menu now cannot be triggered.
  16. Some fixes regarding low level rendering stuff.possibly fixing custom-map shadow map renders.
  17. Game no longer automatically unpauses on resume from alt-tab, if it was previously paused.
  18. alt+tab now pauses all the games music and sound effects correctly.
  19. Bugs with online xp being calculated and applied wrong, and ranks not leveling up should be fixed.
  20. Fixed bug where bolt action rifle could not be unlocked.
  21. Clouds are more transparent and can be controlled by editing OPTIONS_MAX_CLOUD_ALPHA in config.txt
  22. Missile damage is reduced.
  23. Changed sound effect for clicking on augmentations.
  24. Removed typo in manual.
  25. Supplies now cannot exceed maximum cap, regardless of dog tags or deconstruction rebates.
  26. Unlocks and achievements now only granted on campaign maps.
    [/code]

#2

I just tried out a custom map again, and point 16 doesn’t seem to have fixed the issue; the map is still without bump mapping. Sorry.


#3

alt-tabbing now working fine :slight_smile:

Getting an occasional issue on the design screen: mouse-over an icon and it’ll show me the description for a weapon above the one I have the mouse over. Drag that icon onto my design and the weapon I got the description for got added.

I think it might be an unlock issue - I’ve noticed it mostly when trying to update designs to include newly unlocked weapons. At a guess the on-screen display of modules is getting out of sync with an updated list underpinning it.

Had a freeze trying to attack my own defended online map, but ended the process and am now getting spanked while attacking. Someone else has managed to play it too!


#4

Could the online game browser please include a “Map” column? I’m kind of proud of the map I made and want to see if it’s being re-used (and play those challenges).


#5

I only just downloaded the patch, but it looks good so far. :slight_smile:

Regarding the hull costs though, it seems to me like Heavy hulls should always cost more than Medium hulls, and Medium hulls more than Light hulls. This is especially true with turrets, since weight isn’t a consideration there.


#6

Alright, lots of improvements, especially the online stuff works now.

Now that we have differences in hulls, I’m missing something:

Yes, I can see that one hull costs more and weighs less, but what does weight mean?

  • is it simply slower?
  • can it take more punishment?

#7

Heavier = slower. Nothing else.


#8

I think heavier hull is slower AND can carry more armoring. In other words when you place same amount and type of armoring on a medium hull and heavy hull, the heavy hull can carry more armoring and thus the armor value is higher.

But I could be wrong too, I haven’t entered into this.


#9

The Heavy hulls can carry heavier armor simply because they’re a different hull (“Heavy”), not because they weigh more.


#10

I’ve had the game freeze a few times now since the patch, so I think it’s a new bug. It seems to happen whenever I have a lot of turrets firing Plasma beams and I’m in any zoom level other than the furthest out. So, it might be related to the sound effect associated with the Plasma beam. So far I have not had it freeze when no Plasma beams are present, but the sample size is only eight games.


#11

I played a challenge map I’d posted, and the AI placed “default” turrets (such as the 88mm turret) that I’d removed from my game. I’m not sure if those were inherited from the map I’d based my map on, or acquired from elsewhere, but it’s frustrating that they’re still included on the posted map.


#12

The bump mapping didn’t cope well with my transition from sand to rock to grass. It’s all square texture with the bump mapping liberally ignoring the colours completely.

(Not really a surprise, and clearly not a priority to resolve, but thought I’d highlight it - perhaps I’m just not meant to mix terrain types within a single map).


#13

Well i’m still waiting to actually get the Update.


#14

First crash
I’ve had a crash after winning this custom map :

Game crashed while I was watching the statistics.

Second crash: In the unit design, after browsing a few units and modifying 2 of them, game hung, and i managed to get a screen of the error message, though I couldn’t keep focus on that message window:
tof.canardpc.com/view/a84d2efd-2 … e84ddc.jpg


#15

Got a crash after playing 10049 and it had attempted to contact Bletchly Park. That took a while, so I cancelled, then tried again. I then tried to alt-tab away, but it had locked somewhere in that process.


#16

Hmmm… tried to download the patch yesterday, it started, then seemed to hang, not sure why, perhaps it was only busy and was taking a while to update, I waited for about 3 or 4 minutes, seems long while waiting, probably not really long at all, but the game seemed to freeze. I had to ctl-alt-delete out and then tried to update again, but other than a momentary connection to Bletchly Park, the game doesn’t update. I am still at 1.001 and wondering if there is a way to force the update? But i see no mechanism inside the game to do so, and have already started and quit then restarted again about 3 or 4 times with no update. :frowning: I figure I am doing something wrong. Or perhaps I am missing something obvious.

Any help would be appreciated,
Thanks much,

-Teal


#17

edit “My Documents/My Games/GratuitousTankBattles/lst_check.ini”
And set the date back a bit.


#18

@Snowdrift,
Thank you very much for the thought, but I tried resetting the internal date back a bit, first to 3-17-12 and then 3-10-12 and finally to 3-07-12, but each time when I restarted the game, I got the really quick check and then stop and no update. :frowning: Again I appreciate the help, but it just didn’t work for me, unless there is a way to actually re-set the date on the file itself, which is date stamped with todays date of course.

Thanks and take care,
Signing off for now, Look out we have Incoming!! :slight_smile:

-Teal


#19

The patch will only download if you have entered a serial code and username previously, I should make that more clear. Is that it?


#20

Cliff,
Thank you for the response. I have my serial number and my username entered in the profile page. I can try to enter it again? Will let you know,
Thanks,

-Teal

p.s. Was just checking and in my …/web/patches folder there is a gtb1002 executable. :slight_smile: While the game internally says 1001. Should i double click this gtb1002 file? :slight_smile: Maybe it downloaded but didn’t run? Or perhaps i accidentally stopped it? and so that is why it doesn’t show 1002? All of this is guesses of course. But if you think it would help, what about a re-install? Thank you.

-Teal

Yep, double clicking the gtb1002 patch installed it and everything looks good now. :slight_smile: Perhaps after the bugs and features when things aren’t quite so hectic you could add a manual update button? Just a thought. Thank you much, am diving into my first edited map, haha, we’ll see how badly i do. :slight_smile:

-T