Patch 1.004 feedback thread


#1

Enter your comments and thoughts specific to version 1.004 here…

[code]version 1.004

  1. Fixed crash on ‘Add Friend’ if username was invalid or already added as a friend.
  2. The Battle screen now allows you to scroll up or down past the end of the map to see any paths obscured by the AI.
  3. Online updater message now disntinguishes between checking for, and downloading the latest patch.
  4. Fixed bug where newly designed units were not assignable by the divisionmanager, or visible until a re-start.
  5. Dog tag flashing duration is now based on real-time, not game time.
  6. Recordings of attacks posted with a challenge are now correctly playable by other players.
  7. Online challenge browser filters now remember their settings.
  8. Fixed a number of display/formatting errors on the messages list.
  9. Fixed crash bug relating to using an empty custom division.
  10. Right clicking a player color on the customizing screen now removes that player preset.
  11. Player is now prompted to enter their user name and try map and unit editing, if they have never done so.
  12. Fixed corruption on module data comparison chart
  13. Fixed bug where bottom item always missed off the module data comparison chart.
  14. Added 2 new campaign missions!
  15. Assigning paths to selected tiles in the map editor now deselects all tiles, making path-setting less frustrating.
  16. Fixed occasional rendering bug on the hull picker.
  17. Fixed bug relating to new maps being created when editing an existing custom map.
  18. Custom map descriptions are now much shorter, to reflect them only showing up in a strip on challenge browser
  19. It’s now impossible to save out a custom map with a blank name or description, plus these both default to blank.
  20. Health bars now have a minimap-button, remember their on/off state and don’t dissapear when you click elsewhere.
  21. Added hotkeys to speed control tooltips
  22. Minimap toggle-buttons no longer confusingly highlight when you mouseover them.
  23. Splash damage augmentations are no longer selectable in the unit design UI unless a splash-equipped weapon is installed.
  24. Generic damage augmentations are less effective, specialsied ones are now more effective.
  25. New icons on the online challenge browser show if a challenge has been downloaded or beaten and if it has a custom map included.
  26. The unlocks window now shows details on all the stats for the choices of unlocks you need to make.[/code]

#2

Looks like some excellent changes!

Ill be testing out the two new maps immeadiately :slight_smile:

Thanks cliffski!


#3

when i start a battle the game crashes :frowning:


#4

is there an error message? did the game work ok before 1.004 or is this the first version you have played?
If you temporarily rename \my documents\my games\gratuitous tank battles, does the game work ok then?


#5

I failed the new snow map while defending. I actually left the game running whilst - and please excuse my digression here - spraying a redback spider infestation. When I came back I’d obviously been beaten. The “defeat” dialog probably popped up when the the VP limit was breached, however it remained on the screen and could not be dismissed until I was able to get back to the main screen. Hope that makes sense, particularly the bit about the redbacks. God I hate spiders.


#6

Hi Cliffski,

I have beta 1.003, when I was starting the game this morning it did not find the update to 1.004. I had recently installed a firewall and I think that blocked my first attempt this morning, so I excluded the gtb.exe from the firewall but the update still wasn’t found, I assume this is because it already marked the daily check the first time when I started, is there a manual way to force the check for a new update even if I already started the game today ?


#7

yup delete the lst_chk.ini file, I think its in \my documents\my games\gratuitous tank battles, or it may be in the \web subfolder.


#8

New icons to indicate custom maps and downloaded challenges are a good addition. Sadly they’re just black squares on my screen :frowning:
The mouseover popups work though :slight_smile:


#9

“On best form at Beda Fomm” comes with no scripted attack or scenario units :frowning:


#10

yes it did work in 1.003. when i start a battle the game just crashes with no error messeges. ps i’m going to try and reinstall it.


#11

Ah, same (no scripted missions or scenario units) on Left, Right.

I think ‘Snow use’ may be an international warcrime too.


#12

Campaign map time limit: 500.00
Post a recording as an online challenge on the same map, online map time limit: 500,000.00


#13

I did that, but still no luck, also changed the date one day back as well after deletion, did not help either, it does not seem to find the latest update. Anything else I can try ?


#14

i reinstalled it and now it works just fine ! :slight_smile: Ps AWESOME GAME


#15

Thanks biotec33, that worked for me as well, let’s see what happens when 1.005 comes out :slight_smile: … actually had to contact BMTMicro support because I misplaced the download info email for GTB and they were very quick in responding, cliffski you definitely picked the right payment provider !


#16

Well, I’ve had my first crash. Pretty simple to make it happen (tried it a couple of times to be sure). Here’s the recipe:

  1. start the game (duh)
  2. select “Battle Browser”
  3. select “Once More unto The Somme”
  4. select “Captain” difficulty
  5. select “Attack!”
  6. select “Scenario Units”
  7. click to enter the game
  8. scroll to the bottom of the map using the down arrow key (it might be necessary to “bounce” off the bottom… I’m not sure but that’s what I was doing)
  9. right click on the Jaguar Assault Mech
  10. music stops, game exits, windows “tries” to find a solution to the “problem”… yeah, right.

This is with 1.004 as downloaded today. My machine is running Vista Home Premium SP2, 32-bit, but I don’t know if that makes any difference.

Loving the game so far.


#17

Excellent bug report, thanks, I’ve reproduced it and am fixing it now…


#18

Have not seen this touch on else where. When I deleted a unit, they come back every time I start the game up again. So when I up date units, and then delete the old ones, they all come back the next time I start the game up. Also if I update a unit and save it with the same name, I get two units with the same name even thought it says it’s overwriting the old file. The two units are different in load outs, the old one and the new one, but both show up. I stop doing this and have added “MK2” to the names to make them different, but as I said, the old ones still show up and I got to delete them one at a time until I have just the new ones left.