Patch 1.16


#1

Just downloaded patch 1.16 but couldn’t install it. Got a popup saying that the setup file is corrupted!
I am using the full final 1.15 release


#2

sounds like the file did not download entirely. Just delete it and give it another try,


#3

OK Sarted again the download and it works