PATCH RELEASED (1.63)


#1

Ok, everyone who has bought the game before 10.23AM GMT will be running 100, everyone who bought after that has 101.
What SHOULD happen:
If you have 100, then running the game should automatically download and run a patch installer (once only). You are then running version 101

What MIGHT happen:
This might fuck up :D. If it does, no problem, just uninstall the game entirely, and re download it using your link sent to you by BMT-micro. you then get a ready-patched version.

Thanks for everyone’s patience. I had intended to wait another day to ensure I could track down the sound-related crash bug, but I’ve hurried this patch up because of this Error 41 crap.

UPDATE: there is a now a 1.02 version. same rules apply as above.

UPDATE: there is a now a 1.63 version. same rules apply as above.

NOTE: read this if you have stardocks impulse, and bought the game through them:
viewtopic.php?f=21&t=3113&p=16234&hilit=installer#p16234


#2

GRATUITOUS WHITE SCREEN!

…I’ll try downloading through the BMT-micro link.

edit: it’s my video card. Disregard this stupid debacle.


#3

Does this patch allow us to turn sound and battle menu back on and take it out of windowed mode? Us being the people who have to do that to play of course. The patch worked as advertised for me, on start up it installed the patch perfectly.


#4

Not sure, but the patch broke formation/escort etc. orders for me, it just doesn’t work when I want to select a ship. Just “beeps” and then doesn’t put its name nor does it draw the lines. Is it me or it’s a new issue?


#5

Running the 1.00 just locks up with the Error 41. I’ll just re-download and start again tomorrow.

Well tried dowloading it tonight, so I could just start playing tomorrow. Alas the download link just tells me the password I was sent is blocked. I’ll have to try again tomorrow.


#6

I’ll try this when I get back from work. Hopefully the blocked password issue is resolved, as my coworker was having similar issues this morning


#7

I can start the game again!

However it seems I can no longer issue any formation type commands in the fleet layout. I’m only testing it in one battle at the moment, I’ll update later if it works in another battle. I’ve tried it with escort and formation and if I drag to set the target when I click nothing happens.


#8

Indeed. This was stupidly broken by me when I was fixing another bug. I have fixed this new, lovely bug and that will be corrected in the next patch. It was a bit of a silly mistake. I added code to ensure that orders that were invalid (you add a formation order but forget to assign it to a parent ship) got silently deleted, but it accidentally also gets triggered when you are in the process of adding that order, which I had not double-checked! It will be fixed by tomorrow though :frowning:


#9

I’m also having the problem where I’m trying to re-download the game, but none of the BTM links will work. It just says “The password is blocked.”


#10

Try again now, I just got them to relax the blocking limit


#11

Nope, same error still.


#12

I’m getting the same from them. Password blocked. Doesn’t give a reason…


#13

I just manually refreshed both your links, you should get the emails re-triggered and the links re-activated now,
Cheers


#14

Thanks. Email turned up about 2 seconds ago and it’s redownloading as I type.


#15

That worked, thanks.


#16

let’s hope others don’t have this problem so you don’t have to manually do it for all of us, lol


#17

I’m also getting “The password is blocked” message and with my current “Error 41” i can’t even enter the game ^^


#18

I’ve been playing around with 1.01 and I haven’t experienced any crashes any more except for the sound-related one.

My compliments on your graphics engine. My laptop usually chokes up rendering shader effects, but your engine runs silky smooth with everything at max (albeit in a window at 1024x768, which I prefer).

FYI:

2 GHz Duo Core
1 Gig ram
Nvidia Quadro NVS 135 (Dell makes it your way, so long as your way falls within the extremely limited selection of choices Dell offers you)
Sigmatel integrated sound card


#19

I’ve experienced a couple new crashes with 1.01, mostly after trying to leave the ship editor.

I was able to enter my password without any trouble though and I’ve been clobbering the challenges :smiley:

Unfortunately I’m going to hold off on playing much more until I can effectively set formations and escorts. No good when my fighters run off and then aren’t there anymore when I need them.


#20

I’m having the same problem as Waseh and the others, Password is blocked + Error 41 means I cannot enter the game to patch it, can ya help?