Patching System


#1

Hello,

Not sure if this has been suggested before, I did try to search but it said that Patch was too common and Patch Download came up with downloading challanges. Anyway I digress.

Recently formatted my computer and today got the e-mail about Nomads. So purchased and then installed everything all at once, the core game and all of the DLC from my backups.

And then it crashed every time I tried launching the games. Much head scratching nothing has changed about my computer, no-one else seems to have reported my issue (SIM_Shiphull.cpp 40 Unknown Bonus Error) So I figured it’d be my setup, un-install everything and re-install everything. Still got the error.

Only was able to find the version number for my installation in the read me, it ended in 35, the lastest is 47. How to get it up to update… hmm don’t remember how, look around no where it seems for a patch to download.

Un-installed everything again. Installed only the core and launched the game, played around with the online section nothing about getting patches there.

Quit outta the game, then went back in and it applied a patch. Now I’ve managed to install all the DLC’s and get into the game okay.

Work around being available it’s probably not a big issue but IMHO I think could do with reviewing the patching system so that it is either available from the website easily and/or having a launcher on the game so that you can patch it up before it tries loading the main game itself. If I’ve missed something that would of made this easier for me someone please correct me.

Thank you.

Nutter


#2

Currently the game only checks for a patch once a day. This is to make the game startup quicker, and not to have the server hammered. It probably should have a button somewhere to manually check for updates. That wouldn’t be too hard to do.


#3

Sorry probably the main thing that I really wanted to stress was the ability to patch outside of the game. If for any reason you get a version discrepancy between the core game and version required for any given add-on you get an error trying to launch the game and thus you cannot get the patches to clear up the issue without first un-installing components. Patching outside of the game and/or version checks on the add-on installations would clear up the issue.

Still not a big problem because you just simply need to install and launch the game before installing any add-ons.

Thanks… I’ll shush now.