Playing under Vista 64bit


#1

When I start the game under Vista 64bit I get following error:


Failed to CreateWindow

Cannot create a file when that file already exists.


OK

Could it be it is trying to update itself?


#2

Is anyone playing under Vista x64? I would like to know is this my pc wrong or problem does exist.


#3

I am using Vista 64, and haven’t been having any problems like that. Sure, I’ve seen bugs, but nothing that seems unique to me, or to the OS.


#4

Playing under Vista x64, no problems here as well.


#5

ditto (no problems)
[well… not that one ;]


#6

Ok. Thanks. I’ll try to download and install the last version.


#7

Downloaded the latest version 1.03. Still same error. This time I deleted all files from debug data directory and launched the application. Only debug file reappeared with following data:

----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Beta 1.03
EnsureDirectoryExists

Maybe it will help finding the problem. I can suppose that it tries to create/recreate a file/directory that already exists and some sort of system configuration/setting prevents it.

Regards,
Maverick

EDIT: Just a thought, do I need directx SDK for debug version of the application?


#8

You mean the beta version?
No because I dont have the directx SDK and the game works fine.


#9

Maverick, did you install it in the default directory? And are you logged in as an administrator? It’s possible it’s trying to extract to a temporary directory somewhere that your user doesn’t have the right permissions for.


#10

I’ve installed it in another directory. I’m logged as administrator. I don’t have any problems with other games. Its first time I have such a problem. I’ll try and install it in default directory to see if this is the problem.

As side note, at office under XP its working fine.

EDIT: Installing in default directory didn’t help. :frowning:


#11

Well… after few days of try and error and a weekend without battles (game is working only on my office PC under XP), I found the cause of the problem. :slight_smile:

You will not believe it :slight_smile: I think it must be in FAQ of the final game.

Take a look at this http://support.microsoft.com/kb/930128. A suppose that game is accessing “my documents” link and this was broken on my vista installation.

Glad it is solved now and I can play a great game from my home PC :slight_smile:


#12

And I’m getting the same issue now!

Purchased on Steam, and having no luck getting it to start. It gives me the same error - except this is Windows 7 64bit. It would seem this revolves around the my docs folder, since there is no my documents folder in windows 7. I’ve tried gaining ownership of the shortcut, creating a fake folder, and every fix on the MSoft knowledgebase. I’m at a loss - any ideas?

EDIT

Okay, by recommendation I changed permissions in my documents folder through the command prompt. Worked like a dream. The one within Windows didn’t work, for some reason.


#13

Holy cow, are Microsoft idiots? That sounds like a major bug of their own making…


#14

I’ve run into quite a few problems trying to run stuff in Vista64, but most of the time the problem can be “fixed” by allowing the program to run as administrator. It’s come to the point where that’s one of the first things I try now if I’m running into problems.

As for the My Documents link, Windows goes nuts if certain criteria aren’t met in your default installation. Windows is assumed to be on the C: drive (you get some…interesting…results if it’s on a drive with a different letter), and the My Documents folder is supposed to be in the default location. If you change the location of the My Documents folder, lots of programs don’t know how to handle that. This includes Windows, which really surprised me.


#15

it’s not that bad - iirc the API for getting the user’s documents folder still works, it’s just the compatibility junction point “my documents” that’s not accesible. this will cause issues for programs that “remember” the last files you’ve opened (word, excel etc.) but shouldn’t affect much else