Policy Icons


#1

Was attempting to flex in a couple of policies, got the numbers figured out, an image downloaded in .dds format, but now I can’t get anything to display alongside the mod. Help showing me where that value is in the .csv file?


#2

Alright, I have both GIMP and the .dds plugin, but I still cant get the black icons to go away. Help?


#3

Badump? I’ve gotten the .dds mod working now in GIMP, but I still get black icons in the game.


#4

Icons must be the right size. I think it’s 128*128 pixels.


#5

Went and tried that. Still nothing. Copying and renaming a policy icon already in place that works (vanilla ones) also produce a black box. When the icon fades out, the true image is visible for a second, but then also disappears.


#6

No…help?


#7

Icon names are taken from the object name for a policy, exactly, with dds on the end. Not the ‘guiname’ but the object name. They have to be dds format, in color (32 bit color) even though they are only generally black and white. They tend to be full white, with the actual icon drawn onto the alpha channel. I leave mipmap generation turned on as well. I use photoshop and the DDS plugin for photoshop.
Black suggests the entire icon is not being found, so I suspect the name is just wrong.