Probably a really stupid question ...


#1

Okay. So I put together a little mini-race pack with some silly overpowered stuff I’ve been playing around with. I set everything up in a separate race structure just like any of the DLC. Then I used the Generic Mod Enabler (as suggested elsewhere in this forum) to get everything put in the right place.

So far so good.

After a few hiccups, I finally got GSB to load without crashing (all my own fault). My new race is available in the races list, with the right picture and text and everything.

Then I went to put together some ships … only to find that my hulls don’t show up in the “change hull” selection list.

Is there some trick I don’t know about? All of my ships are directly based off GSB stuff (to minimize the ways I can screw it up), and I left a lot of stuff alone for each ship (mostly changing the color and some of the stats, but leaving things like engine glows, running lights etc. as is).

I’m out of guesses at this point as to what I’m doing wrong. :frowning:


#2

Is the file path to your ships hulls “yourmod/data/hulls/race” or something like that?


#3

Have you changed the race name in the hull file?


#4

File path is: MODS\ace\data\hulls\ace (MODS is the folder the GME set up, and “ace” is the name of the mod and the race name)

Yup, I did double-check that (especially since missing it in a couple spots was making GSB crash before).


#5

the race name is case sensitive . . I have been caught by that a few times


#6

I kind of thought it might be, so it’s all in lower case everywhere except the places where it’s text to be printed on the screen. (I was following the example of all the other races.)


#7

Let’s see…

Folders are right.
Race name also seems to be right.

Mmm… Can you put up here the begining of one of the missing hulls? (just the part before the hull bonus code)
The problem should be around that part.


#8

Okee dokee …

This hull is based off the Federation Panther Cruiser. I did remove the hulk, but assumed that since the Rabbit Cruiser and Imperial Weapons Platform run that way it shouldn’t be a problem.

[config] classname = cruiser name = Ace Doomstar Cruiser hull guiname = Ace Doomstar Cruiser Hull sprite = Ace Doomstar.dds damagetexture = Ace Doomstar_damaged.dds width = 160 height = 160 powerproduced = 14 cost = 250 racename = ace


#9

This one has me stumped . .
Instead of using the mod manager for now, have you tried to place your mod in manually ?
(becasue, from what i am reading, everything appears to be in the right place)


#10

I haven’t, mainly because I wasn’t sure exactly where to stick the stuff to make GSB pick it up correctly. Do I just put it in the way Tribe, Order and Swarm are set in?

The weird part is that I can actually select my modded race as the primary, I just can’t design any ships for it. Why it would pick up one part but not the other is a mystery to me.


#11

yeap, so you will have the following subdirectories in GSB

  • ace <- your mod directory
  • data
  • directx
  • order
  • swarm
  • tribe

Then in ace directory you will have

  • data

which will contain all the mod info


#12

Well, tried putting it in manually, and the race no longer shows up as a selectable option.

EDIT: And then I reactivated the mod through the GME (because I deactivated it before putting it in manually), and now the hulls are showing up in the design screen. Chalk another one up to the mystery of computers I guess. I’ll revisit this thread if I have any other issues. Thanks everyone!


#13

Your race disappeared because the official mod installation method requires a text file in GSB/data/installs that lets GSB recognize the mod.
Good to know it works for you now. :slight_smile: