Problem running GSB with no sound card


#1

Hi,

When I start GSB, I get the infamous sound driver error :
ERROR - FMOD[Failed to getDriverCaps] (37) An invalid parameter was passed to this function. :…\src\GUI_Sounds.cpp 661

I’ve searched the forum for answers and I found some ; the problem is, I’ve got no sound card in my computer !

What can I do to disable the sound in GSB, so it will start ?

Thanks,
David.


#2

Next time post your problem in the Support Forum my friend :wink:

Anyway, I’m not 100% sure this will work, BUT!! It’s worth a shot. Go to C:\Users****\Documents\My Games\GratuitousSpaceBattles\prefs.ini, then set sound_channels to 0. Keep it like that until you get a new sound card, then set it back to its default number.


#3

Thanks for your answer ; you’re right, I should have posted in the Support forum, how dumb am I ?

Is it possible that a moderator would move this thread there, please ?

Anyway, I tried your solution, but it doesn’t work. Still get the same message :frowning:

Cheers,
David.


#4

damn. I didn’t think it would work, but I still had hope DX

Well, another solution would be to go to the same folder as the one i specified earlier, except open the file config.txt. You should change all these specified values to 0:

HARDWARESOUND
OPTIONS_SFX
OPTIONS_MUSIC
OPTIONS_MASTERVOLUME
OPTIONS_INTERFACE_VOLUME

That’s probably overkill if it does work, but try it anyway. :stuck_out_tongue:

And if it doesn’t work, try posting another thread about the problem in the Support Forum. It’ll probably get more notice there.


#5

Has there been a resolution to this error found? I’ve spent about an hour googling around trying to find a fix. I’ve tried every suggested way of fixing I can find. I got the game in a Humble Bundle, and ever since investigating the game I’ve been itching to play.

I’ve tried:
the Humble Bundle download, the Demo version, and the Steam version.
Turned off all suggested sound options in the preferences/config.
Cried.