Problem running GSB with no sound card


#1

Hi,

When I start GSB, I get the infamous sound driver error :
ERROR - FMOD[Failed to getDriverCaps] (37) An invalid parameter was passed to this function. :…\src\GUI_Sounds.cpp 661

I’ve searched the forum for answers and I found some ; the problem is, I’ve got no sound card in my computer !

When running for the first time, the C:\Users****\Documents\My Games\GratuitousSpaceBattles\ folder contains “unfinished” files (folder zipped and attached)

What can I do to disable the sound in GSB, so it will start ?

I already tried copy/pasting text from someone else’s config.txt and prefs.ini, and following the advices of Hybrinoid (thanks!) about setting sound_channels to 0, and HARDWARESOUND, OPTIONS_SFX, OPTIONS_MUSIC, OPTIONS_MASTERVOLUME, OPTIONS_INTERFACE_VOLUME to 0.
Didn’t work :frowning:

Thanks,
David.
GratuitousSpaceBattles.zip (2.43 KB)


#2

DAMN! That didn’t work either.

Hrm… Unfinished files, you say? Odd… Welp, I don’t know what to tell ya! Corrupt files? Idk.