Problems adding custom hull

Since cliff released the hull editor I’ve been trying to get a ship set up using it, a completely custom ship using a custom sprite and everything. I have it so the game can load the mod fine with the mod loader, and the ship hull should be properly set up. However, the ship does not appear in either the hull editor or the normal ship design screen.

Hi, the editor isn’t actually a hull editor but an ‘element’ editor. Each ship hull needs a corresponding element file inside
Otherwise although the hull exists, it has no actual content. Does that make sense? I can go into more detail.

Having the same problems. In my case, the game crashes everytime i try to start a deployment or going to the design section. Also, i cant load my custom hull even if i have the element defined in my mod folder. I suspect the problem also may be the dds files. Since i dont have a clue (as everybody else) which parameters use to save em (and the info about it is soooo ridiculous limited) maybe the game doesnt like em.

TheMightyCat11 did you solve your issue?

So i have a mod called “Stargate”.

Thats the name of the main folder that i put on the /mods folder.

Inside that folder i have the Stargate.txt file, within another folder called (again) Stargate.

Inside that Stargate folder i have the next folders (just to have some order) and files inside ->


Inside the bitmaps folder i have the files,,, these are the ship sprites. Also i have the images for the mod info and the race portrait.

Inside the elemtents folder i have the file tauri_daedalus_elem.txt , that is the element file for the hull.
Inside the hulls folder i have the file tauri_daedalus_hull.txt, that is the hull file of the ship.
Inside the languages files i have the folder “English” and the folder “races”. Inside the races folder i have the file Tauri.txt

And thats it. Whats wrong? the “new” race never shows up. The hull doesnt show up in the design screen either and also in the editor.

At this point , ive been trying for 4 days now and i cant get it working. Ideas?

Its curious i also tried using vanilla hulls to see if that worked… no luck lol. I also tried using vanilla dds files just in case it was something about the image size or watever. I also tried to use files within the vanilla folders to make sure i am not making any mistake or missing something. No luck.

Maybe the game just dont want custom mods at all???