Rad Gun not firing--bug or feature???


#1

Just spent some time playing a solo challenge, had an Order cruiser geared up with Rad Guns.

None of them would fire. Tried it twice. Not one shot. Not a range issue. Not an order issue (although sans other targets, even if I’d deleted target cruisers, they should still have fired).

Made a new cruiser with some better defenses (even dusted off the hardly-ever-used Emp defense module), some Rad Guns, and a Nuke missile launcher. This design: 2 of the Rad guns fired…2 did not.

I notice the firing weapons all have a little white dot in the upper left of the icon module as one views the ship during the battle.

Am I forgetting some basic GSB thing in my senility??? Or is this a bug?

RC


#2

The white dot means the weapon module has a target. If it doesn’t, it probably isn’t in range. Remember weapon range is calculated from the location of the weapon module to the center of the targeted ship, so it’s entirely possible that some of the rearmost weapons were not in range while the front ones were. If you removed the order to attack cruisers, your ships probably moved just enough to get the front weapons in range but not enough for the rear ones. That’s why you should always make sure your ships have attack orders for all ship classes, so you can set the distance a little lower than your weapons’ range, as this range is calculated from your ship center to the ennemy’s, so there again some weapons could end up out of range by a dozen meters if you stick to the desired weapon max range.


#3

What part of NOT A RANGE ISSUE was unclear for you?

To be more clear: all non-firing weapons showed as “in-range” according to the firing radius shown when clicking on the module icon. Also, this was a one on one ship duel with both ships starting very close. And in case I have to be even more clear: NOT A RANGE ISSUE.

:slight_smile:

So why is it some Rad guns show as in-range and fire, while others that appear to be in range on screen–well in range–don’t show the “in range” dot and don’t fire?

Remember, I also had one cruiser armed with nothing but rad guns with this same problem affecting EACH Rad Gun, and another cruiser with 2 firing and 2 not firing. . . .

RC


#4

I just checked, rad guns definitely work. Way to go, good luck finding help next time.

Smartass.


#5

It means that the turret crews have gone on strike to protest inadequate pay and unsafe working conditions. If your weapons officer is named Eugene Debs, you may be in for a real headache.
(maaaaajor tongue-in-cheek)


#6

If Debs is involved, going to have to go with droid crews. . .of course, there’ s nothing to keep THEM from learning radical ideas. :slight_smile:

RC


#7

There is actually nothing special about radiation guns in terms of game code, they are just bullet firing modules that have a radiation payload. The moduels themselves are definitely intact? and there are no other targets they could be engaging?
If you replace them with bullet weapons it works ok?
Is it that they are not seen to fire, or not actually firing? do their turret stats show they have not fired?
There is a limit to the number of shells that can be drawn, and in very over-the-top firefights sometimes a few get silently ‘dropped’ visually (but still fire). Thats only when you have hundreds of ships though.


#8

I’ve played the game for quite awhile now, and the situation is as described in my original post.

Online challenge vs. 1 enemy cruiser. Small map–within engagement range. First cruiser I tried was a previously designed Order cruiser with 4 or 5 Rad guns. None fired. I viewed the range-bands by clicking the Rad gun icon on the ship display–enemy cruiser was within the border of the white circle and outside the border of the red circle. Very weird.

I design a ship from scratch with 4 Rad Guns, different hull. It goes in and I see Rad guns firing, but the rate is not has high as I had hoped, so I start clicking through the rad gun icons, checking each in turn. Two are firing–as one can see in the stats box to the left of the ship’s module icons–and two are not firing–shots fired 0 and so on. Even weirder, I thought, than NO guns firing. While the range bands for firing and non-firing Rad guns are a tiny bit different–as they are in different positions on the cruiser–there is nothing to distinguish the visual range info. Firing weapons look like they are in range, and non-firing weapons are in range.

I know this is so weird that the obvious answer is “stupid human error,” but I swear on a stack of pancakes that I know what I’m doing and I know what I saw–and I repeated the challenge several times to confirm the problem. I’ll go back in and find this challenge and see if I can record more details, or if it repeats. . . .

RC

I belatedly realize I have omitted an important point: this IS on the Mac version at 1.48.


#9

RC, i run mac 1.48 and don’t get that error. Veil Nebula spawns waves with Radiation Guns, and i never have any problems with them not firing at me!


#10

This is definitely different WEAPONS and not different hardpooint turrets linked to a single turret yes?


#11

Yes. First cruiser and second cruiser, multiple Rad guns. Cruiser A didn’t fire at all; Cruiser B half the weapons fired.

This has only occurred during this challenge: 4634967, posted by harly. Single Tribe cruiser is the enemy.

Now here is where I REALLY hope Cliffski can hit the database and review all the Red Cinema attempts, because if that’s possible, Cliffski, you’ll see that I just played that challenge with Cruiser A, which of course the first time out failed miserably, because its weapons, all Rad guns, didn’t fire. THIS time it won handily–which I had guessed it would have done the FIRST dang time I tried it. So the record should show that the first and maybe second time I tried cruiser A (called ORD CR solo) failed, while the most recent attempt with this very same cruiser succeeded–because today all the weapons fired as expected.

Cruiser B is called ORD CR Super Solo.

Now, if only there is database that keeps such records, I won’t be viewed as a crazy weirdo who hallucinates things. :slight_smile:

RC


#12

could you email me the designs of your ships, and the deployment you use, then I can break in the debugegr and watch the gunners make their decisions.
NO THIS WILL NOT EVER BE A FEATURE :smiley:
I’m cliff@positech.co.uk


#13

replicated the bug and took pictures. what a relief to NOT be crazy.

unless I’m hallucinating.

uho. . .

RC