Really flaky ship editor.


#1

Look it’s a mess, but it should be enabled if you add -editor to the command line of GSB.exe, if you have version 1.39 or later. Its a new main menu option (hull editor)
There are instructions here:
positech.co.uk/gratuitousspa … ditor.html
you still need to know a bit about editing the files.


#2

its “kinda” buggy and slightly annoying in some aspects,but i still LOVE you
marry me?


#3

Cliff you are AWESOME :smiley:

Despite it has some bugs, it’s better than nothing and at least now I can easily check if the sparks and smoke effects are correctly in place without having to enter a battle each time and letting the enemy blow up my ships.

P.s. To anyone using this, do not load the Federation Rabbit Cruiser hull!! The game crashes D:


#4

Would one of you kind gentlemen (or anyone else!) advise me how to enable the Hull Editor?

Despite considerable research, it just won’t activate. I’ve tried repeatedly. Cliffski sent me some help but I’m afraid it did not correct my specific problem.

The entire operation should be fast and simple, but my PC is stubbornly complaining that my desktop shortcut to the .exe can’t accept the “-editor” parameter because it claims that something is wrong with the directory path. I’ve already been advised that the editor is actually built directly into the .exe itself, so the path should already be perfect.

I’m stumped by this problem and am quite annoyed that I may be overlooking something very basic. This wasn’t the kind of “really flaky” behavior that I was expecting. :stuck_out_tongue:

Any insight would be hugely appreciated. Thanks!


#5

The path of my shortcut to gsb is this “D:\Games\Gratuitous Space Battles\GSB.exe” -editor
I think you need to get out those " to get it to work :smiley:


#6

I can’t wait to try this out, however I probably won’t get to use it until tomorrow D:


#7

SirJamon, you are a wise modder. I elevate you in the GSB nobility to the rank of Hidalgo Galáctica. :slight_smile:

This was my problem… I had been adding the text -editor within the quotation marks enclosing the directory path. That didn’t work.

Then, I tried removing the quotes entirely. Windows didn’t enjoy that, either.

After reading your post, I realized that I hadn’t yet tried leaving the directory path text unchanged and simply adding the new code OUTSIDE OF the quotes.

It opened instantly. At last!

I’m making this post in such detail because I believe in the old saying, “If you can’t serve as a good example, then at least you can serve as a horrible warning.” Hopefully I’ll be the only player who goofed-up that process, but at least I’m writing everyone a map to avoid the minefield that I rushed into face-first. :stuck_out_tongue: Now I can brace myself for wrestling with the half-complete and semi-documented weirdness of the Hull Editor itself…more aggravation, but less tedium. :smiley:


#8

Hey Archduke, did you do this on a PC or Mac?


#9

I did that on a PC running Windows. If you’re playing the game on your Mac via a Windows virtual machine like Parallels or Boot Camp, it should (knock on wood, lol) work the same way.

For Mac players using a game emulator such as CrossOver Games, I think those folks are out of luck. I sure hope that the Hull Editor utility will also be ported to OS X sometime after GSB itself makes that transition.


#10

NOOOOOOOOOOO! ****!!


#11

Let me guess…GSB via emulation?

I assume you own an Intel-based Mac instead of an old PowerPC-based Mac. Do you have access to Parallels or Boot Camp? If so, all you need is a valid Windows install disc (XP, Vista, whatever) and then the true adventure begins. That “fun” reminds me why I prefer to use a Mac.

In the end. It depends how much pain you’re willing to tolerate in getting there. Creating the foundation for a full Windows virtual machine just to have the editor sounds like a poor investment of your time. The editor really is buggy and maddeningly incomplete. Yes, I have it on my PC, but the editor has its flaws. Right now I’m stuck trying to get it to open a ship other other than the one it randomly starts with…all attempts to break out of that make the editor crash and it takes down GSB as well. I wish it wasn’t so frustrating to use, but cliffski did warn us…


#12

For those of you who got GSB through Steam, please note that you can’t edit a shortcut to use the editor. It’s a quirk of how shortcuts to launch Steam games work (it calls in the Steam .exe with a command line argument to launch a game with ID XXXXX, so the command for GSB via Steam is “C:\Program Files (x86)\Steam\Steam.exe” -applaunch 41800).

The good news is, Valve realized that might cause issues and set up a workaround: First, open Steam itself, go to the Library, Games sub-section, find the entry for GSB, right-click on it, choose Properties, and then Set Launch Options; from there, you can set whatever command line options you want, as long as you know them.


#13

Another way is to navigate to inside your steam GSB folder where all the files are, and make a shortcut or whatever to GSB.exe right there.

Also, speaking of editors, a scenario editor would be awesome. Manually creating them is tedious and boring


#14

doesnt happen here :smiley: what error message do you get? if any?


#15

For me it only crashes with the Rabbit Cruiser and I’ve tried all the hulls from my mod and some from the Star Wars mod. Also, the few vanilla GSB hulls I’ve tried work.

I’ll leave here some feedback about the editor for when you finish the campaign mode. Don’t worry in fixing it now, we want to play the campaign :wink:

  • The standard module slots seem to be bigger in comparison to the harpoint slots.
  • It’s great having the visual effect of sparks and smoke when editing the damage, but the smoke is so big in small ships that I can’t see the damage box :frowning:
  • This, isn’t really a problem for me because I normally close gsb after having a look at the hulls, but it stays in some game menus (main menu & deployment screen I’ve seen it for now).
    I haven’t tested it much yet, if I see something more when I get some time I’ll post it here.

As I said don’t bother in fixing some of this stuff right now. The modding community has already created great mods without using it :smiley:


#16

I think a hotkey turns the emmiters off. Might be U.


#17

And of COURSE my PC breaks for some goddamn reason… I think the hard drive is broken or something, it gives me a message like that on startup.

This would make modding my ships a lot easier… right now, I’m trying to refine my first mods, but hardpoints are flung off the hull, and the editor would really help here. Hey Cliff, when the Mac Port comes out, would it be able to take in my modded ships that I made on the PC version? (And I hope it has the hull editor as well?)


#18

D’oh! I read the instructions in a rush and completely forgot this morning about that hotkey. It turns off everything except the smoke and spark visual effects when editing the damaged parts of that hull. Well, this way I see better the sparks in big ships without having to enter a battle :smiley:

@Archduke Astro
I’m glad it helped my little post :smiley:


#19

Ships are just text so I assume that the mac version will be fine with them. Not sure about the editor, the mac versions may run very slightly behind.


#20

After using the editor and returning back to the main menu the part of the editor stays on the main menu picture. as part i mean that on the right side… that one that changes when you select different part of ships hull that you want to edit

i have installed your 1.40 patch