Regarding the in-game updater.


#1

First of all, no kissing up intended but I wanted to say that I really support what you’re doing, Cliff. Many a time in the past have I harped on about the game industry, how worthy a role the indie developer plays (especially those who price their games fairly) and how truly important it is to keep good public relations between developer and user. I know some developers might be shy but when they make the effort, it’s all for the better really.

That said, I bought Kudos and I’m very happy with it.

There is one suggestion I’d like to make though, since I actually did, at one point, cause the game to brainfart and completely lock up. It was a bit of a worrying lockup too since it wasn’t the kind I can usually get out of (the ever ubiquitous Winkey+R > cmd > alt+enter solution). I did worm my way out of it eventually but it was still a tad worrying. Still, those reading this are likely wondering ‘Yes but what was the problem?!’ and thinking ‘Would you stop babbling and get to the point?’. So without further ado …

The updater doesn’t seem to be prepared to deal with software firewalls. I use Kerio Personal Firewall as my personal firewall and usually I just switch away to setup rules as the popups arrive. However, it seemed to send Kudos into a loop and I found myself locked up like that for at least two minutes before I managed to get Kudos to crash. The firewall wouldn’t allow Kudos to continue without the rule being setup and Kudos wouldn’t allow me to switch away to get to the popup, so it was a bit of a Catch 22.

The solution I suggest for this is having a dialog that appears the moment one clicks refresh with a cancel button in it. That way, if Kudos gets all brainfarty, one can simply cancel. The mouse cursor did seem locked in place though when it was looping like that so the solution might be a tad more involved than just doing that.

Anyway, I just figured you’d like to know.

For those with software firewalls, I suggest setting up the following rule.

Application: Kudos.exe (o’course)
Single address: 70.85.214.66
Single port: 80
TCP and UDP: Permit both ways.

Your firewall might have a different setup to mine but that information should be all one needs regardless of which firewall it is, most are the same, just laid out differently.

Sorry if this has been mentioned before, I didn’t see it in the stickies or the known bugs thread and it is as much of a request/suggestion as it is a “bug” (since not everyone has a software firewall) so …


#2

I like to bash on software, so I did some testing.

I removed Kudos from my ZoneAlarm Free permissions and ran the program and attempted to refresh the updates list. The popup showed and allowed me to accept (or deny) the request to have internet access.

Locked ZoneAlarm Free then started up Kudos. Tried to refresh the updates. I was able to alt-tab in Win XP, but mouse cursor remained stuck in Kudos for less than fifteen seconds. Received error message - “IERROR: Internet: HttpSendRequest() Failed”. Program then crashed.

Unlocked internet, started Kudos, locked internet manually, did same as above, did not try to alt-tab. Eventually after 15 seconds exactly, windows returned with a blank title bar at top of screen and control of mouse existed. Was able to X-out and program crashed.

While internet was locked, I then tried to access community. No errors reported, however a window did not open in Firefox. Possibly because connection was established?

I closed out FireFox, then re-attempted. Firefox did open a window, and reported a standard server not found message. No effect on the Kudos program.