Repeated crashing in Campaign mode


#1

I bought the Collector’s Edition pack and Galactic Conquest.

In every single campaign attempt I’ve tried, it’s crashed (GSB.exe has stopped responding). Once that campaign save crashes, it becomes impossible to load. I’ve uninstalled, deleted all save game content, and reinstalled. I’ve tried different races and maps. I’m at a loss for what to try next, and I’m annoyed that I can’t play what I’ve bought. The longest campaign I’ve been able to run is (I think) 90 weeks. I’ve probably had 10 campaign saves that I’ve deleted as they crash 100%.


#2

Well, this is a disappointing lack of a response. I’d ask if there were other support channels, but I think at this point, my enthusiasm has dropped to the point where I’ll probably just not play (or recommend the game).


#3

Sorry to disappoint MCOBigBen,

Unfortunately our response time is not what it used to be as our active member numbers have somewhat dwindled. While the handful of us that still remain do try to help everybody where and when we can, I am sorry to say that sometimes it might be faster for you try and resolve the issue yourself and post your solution for the next person.

Therefore, until one of our members can find the time to help you with your Campaign Error, my only suggestion at this point is to have a look at some of the previous solutions found in this support forum which may give you some ideas on what to try next.

Also, I strongly suggest that you post some more info on your setup and any of the error reports. While it might seem trivial, sometimes the information you post will help a forum member identify a possible solution.

Information of Interest:

  • Your platform and operating system
  • Version number of GSB (found in top right of start screen)
  • Firewall / Antivirus (Galactic Conquest requires an internet connection)
  • Any Mods you might have added
  • The error reports (found in \My Docs\My Games\GratuitousSpaceBattles\debug)

#4

I’m disappointed in the people I paid, not the volunteers helping with support. :smiley:


#5

Well, my suggestion is still to post up as much info about this issue as possible (because based on the current information, I can only suggest random ideas)
Also have a read through this forum so see if there is anything that might prove useful.


#6

I did have a read before posting, but didn’t find anything relevant.

I investigated on my own after posting, and decided it might be due to changing networks while the game was running (I do a lot of VPN’ing for my job). When I was careful to never have the game running when switching networks, it seemed to crash less. Could be a red herring, but I’ll leave that there for any future problem encounterers.