Restricted Vanilla Modules

This replicates my experience.

Sorry for not being more precise Kemp !

No problem, it was my mistake with regard to understanding you.

This still leaves an issue with resolving the problem. If I have four modules, each restricted to one of the C4 and each with the same internal name, then only one will be recognised in-game.

As i was saying, it seems to me that if they all have the same characteristics, it won’t make any difference. Let’s take the cruiser laser for instance. For all the C4, the charactestics are the same right ? The only difference is the sprite, which is determined by the race file. So whether it uses one file or another makes absolutely no difference. You would still have the correct turrets in gui.

Going to try with Cruiser laser right now and will report later.

But you’re forgetting the race restriction - only one race will be able to see it (the one which owns the first copy that happens to get loaded).

Well, i didn’t really thought it would interfere. So I tried anyway and it appears to work. One of those IT mysteries i suppose…

What i did :

  1. Rename the ‘name’ from all cruiser lasers to ‘cruiser_laser’ [for the 8 races]
  2. Deleted old ships
  3. Created a new ship (empire) with all cruiser lasers and a pulse laser (as a control) <— ship design OK
  4. In deployment zone (on the side) : everything ok
  5. During combat (vanilla scenario) : everything OK

Is there anything else to test ?

Try the same with a Swarm ship also (to be sure that Empire wasn’t the randomly chosen favoured race).

Just tried. Still works. Actually i tried in the ship editor for all races, and in game for empire + swarm.

That’s… interesting. Honestly I can’t see how that’s working unless the modules for each race are stored separately. Maybe Cliff did that to speed up finding particular modules and we just happen to be able to take advantage of it? Anyway, I’ll repackage RVM to use this technique and post a link in the first post tonight (GMT) and let’s see if it destroys anything :slight_smile:

The Cliffski works in mysterious ways, Kemp…


Ok, I’ve put up the new version ( Could you check against the challenges you were having problems with knightofni?

Thanks kemp. I’ve just reposted the challenge here

I suppose we’ll know soon if it works properly. Already one attempt, so at least ppl can download.

Then i thought about something else. Is the package file still needed ? It seems to me that the modification you just made makes it irrelevant (i unselected the ‘RVM’ package - otherwise ppl without couldn’t play it)

And finally, thanks for updating the mod !

fix that every race have the powergenerator because all my rasec that is by modders cant get the powergenerator and to use them I have to change everything in the moding race so pleas fix that everyone can use the power generator

As I understand it, you’ve applied the RVM mod and some of the modded races you have installed are assuming that the vanilla modules are always available? This is unfortunately an inherent problem with a mod such as this, particularly early on before it is adopted by other modders. There are basically two options:

  1. More mods get packaged up to be compatible with RVM. I would, of course, like this and can provide support to make it happen.
  2. RVM fails to be popular and we go back to having to ignore the vanilla modules in the lists for new races that aren’t meant to have them. I don’t like this as it ruins the feel of new races to have their cool new modules mixed in with a load of vanilla ones that are never meant to be used.

Opening up specific modules to modded races isn’t something I’d like to do with RVM without a compelling reason, as we would be back to a subset of the vanilla modules being forced on every new race.

For the moment, unless you have a mod which requires RVM, it’s best not to use it. It is, in essense, a pre-requisite for other mods, not something that should be installed for the sake of having it.

Any Progress?