Retreat Causes Crashes


#1

I am attempting to work the beta release but am getting frustrated with the retreat command. Upon confirming the retreat the game immediately crashes (3 times running). Here’s to getting that patched up.


#2

Weird, worked just FINE for me.
heck, i retreated at least once per world with my scout ships!


#3

I seem to have found an underlying problem/cause to the crashes. Initializing the retreat itself does not cause it to crash. It is any subsequent clicking on the screen that causes GSB to crash.


#4

Are you definitely running version 1.48 of the game? All bets are off, crash-wise if that is not the case.
Check the top right of the main menu screen


#5

I have just experianced the same problem! I have checked and i am running v1.48


#6

It has just happened the second time itried to retreat, on planet kasheeman


#7

The same happened to me as well, retreat - crash. Game auto-updated to whatever the last version is.


#8

Ok, to anyone who can replicate this, please send me the last 100 lines or so (copy the text) of this file:

\my documents\my games\gratuitous space battles\campaignprogress*campaign name*\debug.txt

to

cliff@positech.co.uk

plus also all the files here:

\my documents\my games\gratuitous space battles\debug

Thanks!


#9

Crashed first time I tried to retreat. A few ships jumped out and then CRASH. Game speed was 4x.


#10

Got it to replicate, debug info sent.


#11

I have been playing as nomads today. Earlier it crashed when i retreated, and i exited the game. when i came back i found that it had reset to the turn before the battle took place. When i next hit turn, and set my fleet up for the incoming attack, all destroyed ships had been placed in the reserve window (by this i mean only the ships that survived had remained deployed.

i hope this helps you narrow down what is causing it.


#12

Just successfully retreated for the first ever time. This time i tried retreating while at game speed x1 opposed to x4. i believe the bug is caused by increased game speed.


#13

I’m having no luck re-creating this crash. At what exact point does it crash, and what error message is given?
one report says its a subsequent click and crash? is that always true? is the battle still being drawn? has any ship gone into warp? does it matetr where you click?


#14

This retreating crash is all over the place for me. I’ve never retreated without the game crashing. It can happen the instant I click on retreat, at the moment of several ships retreating, or at the moment of one ship retreating. I suspect that it’s when the first ship warps out, since, if fighters are present, then can warp out almost the moment I click on the retreat button if facing the right direction. More testing required.


#15

Could you see if it happens if the UI is turned off during retreat (the U shortcut).


#16

The crash is variable when it happens. I tried to turn off the UI to test your suggestion but the game crashed immediately upon confirming the retreat (2 fighter squads and a frigate). I can’t reproduce it with just fleets of frigates, but I don’t have a save where i can test cruises by themselves. Fighters seem to be the common theme to the crashes, the UI making no difference when I turn it on or off.


#17

Interesting, so it may be fighter related. Unless anyone can 100% confirm it happening without them. I’m wading through code trying to find something that could go wrong.
Can people get it to happen if they retreat right at the start of a battle, without doing anything else?
What actually happens? Does the game just close? or does windows give an error?
Thanks for your help


#18

In fact, if anyone can repeatedly trigger this bug, in version 1.48, and would be willing to help out, can you email me at cliff@positech.co.uk, and I’ll send you a debug testing version to try and work out what on tatooine is causing this.
Thanks,


#19

I’ve not had anymore retreat crashes after reinstalling with the V1.48 integrated version of the game. Could someone, who is having the retreat crashes, also try re-installing from the V1.48 integrated version?