Saving unit designs trough the Steam version


#1

Hi,

I have the same troubles like some here with the Steam overlay running and yesterday when I tried to design my first turret something went wrong and like most I start the game without Steam now.

It seems that my designs are saved in the “C:\Users\Mark\Documents\My Games\GratuitousTankBattles\player_units” (running windows 7) but the one I tried to create yesterday is in the “D:\Games\Steam\steamapps\common\Gratuitous Tank Battles\data\sampleunits”. Maybe this has something to do with the problems?

Is there a way to obsolete old designs or is it just deleting files from windows?

Thanks for a great games.

Cheers
Mark


#2

That’s very interesting, and may help me code a way around this ‘running within steam’ error on saving. It seems the game thinks the shift key is down when run from the steam UI (only for certain players). I’ll patch it so it cannot be confused, although it’s a mystery why this is happening at all…


#3

Great, looking forward to test it out when its ready. I also ended up with the basic light tank, the black one looking like a t34, is looking normal in game, when placed as an attacker, but the icon is the machinegun icon ???


#4

I have encountered this problem a number of times, as well. It seems to disappear once you redo a campaign.

I have resorted to running the game without Steam, as the unit design menu is entirely unusable for now. The game seems to be saving my unit designs as sample units, and refuses to let me overwrite them until I delete them manually.