Scenario Restart crash


#1

I’m having an issue with scenario. Often when I try to start a scenario GSB crashes when I hit a key after the “Press any key” appears during the loading process. Specifically, this happens when I begin the scenario, use the “Esc” key to return to the deployment screen, then start the scenario again (whether fleet is changed or not). The game generates the following error in the “errors.txt” file:

29/12/2012 - 0::25 - Untranslated HRESULT
29/12/2012 - 0::25 - D3DXCreateEffectFromFile failed

This doesn’t seem to happen with all scenarios. I need to do more testing, but it seems to happen with large and/or modded scenarios. I do not believe anything happened when I tried this with the Tutorial scenario, which is small and vanilla.


#2

I may be completely off-base here, but I seem to recall Cliff mentioning that those errors are usually shader-related and are not game-killers. (My errors file is full of them from pretty much every time I’ve run the game lately, and I haven’t seen any problems while actually playing.) You may be having a situation similar to the challenge list bug that several of us have seen, where a specific sequence of actions (view a challenge’s details, return to challenge list, attempt to scroll challenge list) crashes the game. The solution to that one so far is “don’t do that”.


#3

Well this full crashes the game. Not unresponsive or anything like that, goes straight to crash. While this scenario has no shaders, they do the asteroid field and 4 terrain effects. I had this happen during the final P.Ind scenario too.


#4

The crash I still have from the challenge list doesn’t actually put anything new in the errors file. The shader errors were unrelated. My suggestion would be to remove your errors.txt file and replicate the crash. That way you know exactly what is generating what. And if you can find a scenario that doesn’t crash the game, play through it and then exit GSB normally to see if that produces any error messages. (I’d do the non-crash experiment first.)


#5

Testing that out, that error message seems to happen every time I start a scenario.

As for the crash, I tested again using 4 scenarios: a small vanilla (“Defending Sirius”), a small and large modded (first and final of P.Ind.), then my level, where the crash did occur. As that level had 4 layers of terrain effects and the asteroid field, I feel it may be related to that. However testing of “The Rockwall Nebula” disproved that asteroids are involved.

The crash must be related to the terrain effects then.


#6

As in, every time, crash or no crash? If so, then that error is probably not related to the crash itself and is the same kind of thing I’ve gotten constantly for awhile now.

Here’s the brief version from my previous instance with that error:

So it may just be a minor graphical thing.

When you actually get the crash, do you get anything in the errors.txt in addition to the repeated error?


#7

It seems to happen regardless of scenario or crash.
Here’s the brief version from my previous instance with that error:

I can agree the error is probably nothing serious. I haven’t noticed any graphic erors, so everything is ok.

Nothing appears at all. Debug has nothing and Drawdebug ends at the loadscreen image. That last bit could be of interest, as it suggests that whatever causes the crash happens before the scenario’s images even start loading.


#8

Well, here’s the only bit of advice I can offer to avoid the crash. Here’s your initial summary of the situation (emphasis mine):

If you return to the deployment screen, then back off to the scenario list, then re-enter the scenario in question, it may bypass whatever is causing the error. (That’s the only thing that worked in my case.) I know this falls under the heading of “don’t do that”, but it may at least do for a workaround. Give it a try and let us know if that keeps the game from crashing.


#9

Going to scenario list and back didn’t work, it still crashed. I also got a challenge list crash for this scenario, cant remember if it the situation was related or not.3

I tried another scenario I had, it was almost identical except it had one less terrain layer. It also crashed. I still believe that terrain must be related.


#10

An expansion on this, when accessing this scenario then starting ANY other scenario this happens. I never noticed this before as this map was used for large tests.

Further experiments were done, and a few possibilities were ruled out:
-Overlapping terrain of the same parallax
-Error caused by rotated layer

All I can still predict so far is that having 4 terrain layers causes this.