Ship deployment orders not working?

I can’t seem to figure out how to properly control the ship’s AI.

When I set priority to

Cruisers: attack priority and move to attack range : both maximum
Fighters: attack priority and move to attack range: both minimum

for my Cruisers. When the scenario is launched, the Cruisers are
still sitting on their @sses and not moving to attack the opposing
fleet cruisers and instead get distracted with the fighters bothering it.

Is this how it’s supposed to work?

This has happened to me in Challenge #4699192 as well as a couple of others.

If I’m reading this right, you are telling your cruisers to engage enemy cruisers at a range of 2000 (max on the range slider). If the enemy is already within that range at the start of the fight (not uncommon depending on the map size), your cruisers won’t be driven to move until the enemy cruiser close to half that distance. At that point, your ships will try to open it back up to 2000 again. Try setting the range value to the max range of your ship’s longest-range weapon.

If you want your cruisers not to get distracted by fighters, try deleting the Attack Fighters order entirely. your guns will still shoot at them if no other target is presented, but they shouldn’t be selected as the ship’s driving target.

Ahhh… thank you, now I think I got it…

I had thought that “move to attack” meant that if a ship type is visible within the MTA range, only then would the ship given that order approach to attack.

From the above though, it seems to mean something more complicated…? (I think I better RTFM… lol!)

Your ship tries to stay between a minimum and a maximum distance to it’s target. Maximum distance is defined by you (range slider), minimum distance is always half the maximum distance.
If your ship is outside the min-max range it tries to get into that range. If it is already in that range it doesn’t move. You should also know that the faster a ship moves, the harder it is to hit it. That’s why I also suggest to use the “Keep Moving” order.

In battle there are also other things to consider (target may change, the other AI orders have also an influence, etc.). My english is not good enough to explain this kind of stuff (and I don’t know how exactly everything works).

In summary (AcePalarum already mentioned the most important points):

  • Set “Range” to the max range of your ship’s longest-range weapon
  • If your Frigates and Cruisers are distracted by fighters try deleting (right click!) “Attack Fighters” order (except maybe Anti-Fighter ships: tractor beam, high tracking speed weapons)
  • Add order “Keep Moving” (except for fighters, they do it automaticly!)

I was playing the emerald nebula, and this confused the heck out of me (the one with the 25% diminished range). I never really messed with the range settings. For the emerald nebula, the range is not adjusted automatically you, so your ships will try to attack other ships at longer range than they can really attack. When you click to adjust the range, it shows your weapons normal maximum range and another number in parenthesis. It took some playing around to realize that number was actually the adjusted maximum range. derp.