Ship designs might still be deleted while in use.


#1

My campaign would not load. I looked in the debug file, and found out that the game had problems finding a specific ship design, and when I looked in the ship design folder, it was not there.

So I opened the ship editor and created a new ship with the same name, and now the campaign can load again.

Normally it is not possible to delete ship designs that are in use in a campaign. I have no recollection of deleting this design, but I could have done it and forgot about it. Except that this is supposed to be impossible.

So I tend to believe either that the game somehow deleted it, which is a bug, or that I did it, in which case it is also a bug, because designs in use should not be deletable.

I am sorry I cannot be more specific.


#2

Just a thought.

You have identified a problem with your GSB and you have solved it. (well done BTW :slight_smile:
Go back into the game and try to recreate the error by purposely setting out to delete one of your campaign design in the game.

That way you can be certain of what happened as it will eliminate one of the two possibilities you mentioned and you would be able to me more specific :slight_smile:


#3

darkstar076. I just did as you proposed, but it proves only that I am not allowed to delete designs in use, they are all greyed out. I opened another campaign, and also created a new one, created some ships in one campaign, and tried to delete them in another, but to no avail. When the game is running normally, everything is wad, and ship designs in use is not deletable.

So this kind of leaves out the possibility that I deleted it myself, as this normally is impossible. So the game must have done it.

But there is the possibility, that the game is not behaving normally, and that it may have allowed me to delete a design. It is not very likely, as I have no recollection of deleting it, but I could be wrong, I do a lot of designs and delete a lot of them.

I had another theory: It seems that GSB saves to disk at the commencement of a game turn, so a brand new design might never be saved if the game crashes or the computer goes down for other reasons; this would explain a lot imo. The odd thing here is that we are not talking a new design, but an old proven one that has resided in my ship design folder for quite some time.

Anyway, I haven’t been able to reproduce the bug.

Btw, my game is version 1.62, and I am only using the dreadnought mod.

Btw my game version is 1.62, and I am only using the dreadnought mod.