[Solved][Bug 1.16a] Severe lag throughout game from startup menu


#1

Windows 7
i5-3570K
32GB RAM
GTX970

I just bought and downloaded the game. Right at startup, the menu buttons seem to lag. Starting a game of any factory size, the game is running at 1-5fps, and doesn’t speed up. There’s no spiking, it’s just consistently low frame rate. Moving the camera is noticeably slow and chunky. Button clicks don’t always register, and tile animations a take forever to complete–the dust effect alone lasts for several seconds, playing out one frame at a time.

I don’t see any other posts about serious lag issues from the menu and upon starting a new game. Any thoughts on what could be causing this given my more than decent hardware?


#2

same here
1.15 worked perfectly fine
1.16 lags


#3

this is totally weird. Have you tried reinstalling entirely? We had a bug in the very first release, but uploaded a new 1.16 which should be fine. if that isn’t it, could you email cliff AT positech dot co dot uk with the files in
\my documents\my games\production line\debug


#4

reinstalling didn’t help
debug files sent


#5

I cant see anything that could be explaining this. Very little has changed performance wise. Do you have steam running? If so could you try without steam? Ditto GoG galaxy (basic integration for both went in, and thats the only thing I can think of, especially if its even lagging at the main menu, when frankly nothing is really happening…)


#6

what i forgot to do was to reboot my pc because i’m an idiot
problem solved


#7

Restarting fixed it. The game is running smoothly now. I don’t recall there being a prompt to restart after installation, but maybe one should be added.

Thanks for the quick response! And developing an awesome game!