[Solved][Bug 1.21 Steam] CTD on start


#1

I have just purchased and installed the game for the first time and it will not launch.

When launching the game, the screen goes black for a few seconds and then returns to the desktop. The debug log reports:

errors.txt

27/5/2017 - 22::4 - D3DERR_DEVICELOST
27/5/2017 - 22::4 - CreateDevice
27/5/2017 - 22::4 - D3DERR_DEVICELOST
27/5/2017 - 22::4 - CreateDevice failed again

drawdebug.txt

Initialising 3D Engine in windowed mode
Driver : aticfx32.dll
Description : AMD Radeon (TM) R9 390 Series
DeviceName : \\.\DISPLAY2
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
hal_caps.PixelShaderVersion >= D3DPS_VERSION(3, 0)
About to Create 3D Device with width: 1680 and height : 1050
Attempting hardware Vertex Processing
Attempting software Vertex Processing

debug.txt

[22:4:58:284]- ----DEBUG FILE----
[22:4:58:284]- Production Line Debug File version: alpha 1.21
[22:4:58:284]- 
GetLogicalProcessorInformation results:

[22:4:58:284]- Number of NUMA nodes: 1
[22:4:58:284]- Number of physical processor packages: 1
[22:4:58:284]- Number of processor cores: 4
[22:4:58:284]- Number of logical processors: 8
[22:4:58:284]- Number of processor L1/L2/L3 caches: 8/4/1
[22:4:58:287]- Desktop resolution is 1680 x 1050
[22:4:58:296]- Initialising Sound Engine
[22:4:58:324]- Finished Initialising Sound Engine

My computer:
intel Core i7 - 6770k
16 GB ram
AMD Radeon R9 390 8GB
Two monitors
Win10 Pro

I tried unplug joystick and gamepad but it didn’t help.
Also i tried to unplug my second monitor it didn’t help.

I found similair bug report positech.co.uk/forums/phpBB3/vie … 57&t=18237
But solution from this report wont help me due to fact that win10 automaticly updates amd driver to version 17.1


#2

Thats a pretty critical error, implying the video card has no hardware support (which is unheard of). Are you sure the driver is installed correctly? is there a warning or error message in device manager?


#3

Well… I just found that I was living with the wrong assumption that the latest version of amd driver is 17.1.1 :confused: After installing 17.4.4 i didn’t experience crash.