Startup crash following Swarm installation


#1

Hi,

Have just purchased & installed the Swarm add-on, and now the game won’t start. I get the usual “GSB.exe has stopped working” under windows 7, with the following info:
Problem signature:
Problem Event Name: APPCRASH
Application Name: GSB.exe
Application Version: 0.0.0.0
Application Timestamp: 4b857c41
Fault Module Name: GSB.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4b857c41
Exception Code: c0000005
Exception Offset: 00005aa2
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I’ve made no mods to the game, and all was fine prior to the update. I’ve tried renaming the \My Documents\My Games\GratuitousSpaceBattles folder to force the recreation, but no joy. Have also tried differing compatability mode settings.

Debug files give the following:
----DEBUG FILE----
Windows 7 detected
GSB Debug File. App version Full 1.35
Desktop resolution is 1680 x 1050
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine

(and)

Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA GeForce GTX 260
DeviceName : \.\DISPLAY1
About to Create 3D Device with width: 1680 and height : 1050
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
Finished initialising 3D Engine
Initialising Render target of 512 X 512 rt_ship
rt_ship
Initialising Render target of 2048 X 2048 rt_offscreen1
rt_offscreen1
Initialising Render target of 2048 X 2048 rt_offscreen2
rt_offscreen2
Initialising Render target of 2048 X 2048 rt_transition
rt_transition
titlescreen2048.bmp
cwfont20.dds
zekton16.dds

Please help - I miss blowing things up!


#2

are your sound/graphics drivers at the most recent? there’s another thread in Support, here, about an NVIDIA issue. I use ATI so I can’t help with that though.


#3

Thanks for the reply; unfortunately all are indeed up to date.


#4

welc.

try reinstalling the whole game?


#5

The other person who posted they were having this problem said it fixed itself when he updated the game to version 1.38. I would recommend doing that.

If you don’t want to wait a day for the automatic update to kick in then just re-download the game from the original email you got after purchasing the game.


#6

yup, the swarm needs version 1.38, all should be well then.


#7

Thanks guys - I’d missed that. All working now!
Appreciate the quick help.