Statistics glitch, deployment crash and honor issue


#1

After installing the 1.02 I went to have a quick game and decided to go for a challenge. Downloaded Cliffski’s fleet and went for a battle. I lost the first one (hey! I forgot to change the ranged cruiser’s maximum range :P), so I went back to the deployment, loaded my setup and decided to switch the buggy frigate torpedoes (the ones changing into anti-fighter rockets) for something useful. Added a more expensive module, saved the frigate and quit. BAM! Crashed. Restarted, tried it again. Crash! The error from the error.txt is as follows:

1/9/2009 - 23::28 - Assertion failure:filename:…\src\GUI_DeploymentAIIcon.cpp,linenum:23,build:Beta 1.02

Anyway, I changed the frigate by accessing the designer from main menu and it seemed to work. I started the battle, crushed the fleet and two issues appeared:

The statistics listed that 2 of my cruisers had taken over 100% hits as seen here - img136.imageshack.us/img136/9707/statisticsi.jpg . However, there was more to this victory - although I hadn’t used about 800-900 cash I hadn’t gained any honor. At all. I wonder whether my previous defeat could’ve caused this issue.

Nevertheless the patch is awesome; so far it’s fixed most of my issues and the challenge browser is a big improvement. :slight_smile:


#2

I’ve had that same bug line, and also got:

2/9/2009 - 0::24 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:136,build:Beta 1.02

All of them where in the deployment screen. I know the one I posted happens when I try to save a deployment to a challenge match that 12side submitted to me. I don’t seem to get that crash if I just do a normal battle so far.


#3

Don’t even bother, you’ll never defeat me! mwahahaha


#4

I didn’t think that challenges actually gave honor. I’m not certain, but I know I’ve never got any from them.


#5

I also thought about it, but then the final screen is a bit misleading, as it lists just “0”. :slight_smile: Manual doesn’t explicitly state that it’s for singleplayer, so I thought it worked for MP.

Edit - there is another small glitch worth looking into. I started using Shift + F for formation, however when you select multiple ships it will link just one instead of all selected, despite showing that you are linking all.