Steam Users Problems Already - Getting Game to Work


#1

Can I just make sure that the Steam Users are not missed out on GTB support as already there are problems getting the game to work proper and issues with Steam not providing Keys, already…

Just in case someone may not know that we buy from Steam for a reason - thanks.

http://forums.steampowered.com/forums/showthread.php?p=30793965#post30793965


#2

Hi, can you be a bit more specific. ‘problems getting the game to work’. Please let me know what specific issues you are experiencing with the game.


#3

I’m getting the same problem. It stutters constantly, not even playable.


#4

Interesting… the game should run very smoothly on virtually any hardware. What system do you have? Have you tried the game in both fullscreen and windowed mode? What screen resolution are you running the game at?
I’m wondering if this is a steam-specific issue, as everyone playing the non-steam version seems to be getting a great frame rate.


#5

I posted a link to the Steam Forums which has my specific problem posted already. Please tell me if you cannot access the Steam forums or would rather not give suppoort there and I will post my problems here, and notify all Steam users that they need to register here.

Can you please confirm whether you will be/will not be, posting on the Steam support forums please?


#6

My specs,

Windows 7
i5 650 @ 3.20 GHz
8 GB Ram
Nvida 9800 GTX+

Resolution: 1600x900

Tried everything already, putting the graphic all on low, changing resolution, windowed mode. Nothing :frowning:


#7

I have just tried the windowed mode and nothing has changed. I also disabled the Steam overlay, because when it was enabled I had an error message-box when I closed the game.


#8

I posted back on steam forums too, but I’m curious as to whether the game itself is really using much CPU (it definitely shouldn’t be using much). Can you try running in a window, and also running task manager to see what it’s doing?
I suspect it’s either a driver issue, or related to steam integration in some way.


#9

My computers quite a bit lower powered then Skooterkid’s and I’m having the same issue with my steam version.

AMD Athlon X2
4MB Ram
8800 GT

I was also thinking system resource usages, but I checked Ram Usages ~50%, GPU is like 20%, and CPU’s like 60-80%. So that doesn’t seem like the cause.

*Edit: Also updated NVIDIA drivers. No change.


#10

My CPU got up to 90% when it froze up for 5 seconds.


#11

I have replied on Steam forums.


#12

Is this causing slowdown just in the battles? or throughout the game?
Have you tried turning off a bunch of options on the options screen to see if that fixes it? (You might as well give it a try with everything toggled off at first).


#13

It definitely seems intermittent, and not related to a lot of combat going on. When I fired up the tutorial map (with the blue instruction boxes that tell you want different parts of the GUI are) it stuttered a few times. Also sometimes when I’m putting down units during the deployment phase I’ll also get a freeze for a few seconds.

When combat’s actually running it seems to run flawlessly for 5-7 seconds, then a stutter for a few. It’s very choppy, and the audio is also disrupted.

The first thing I tried was reduction of settings so everything is off and the details completely down.I’m also trying it at a 1024x768 screen resolution. Is there anyway to completely disable sound? I’m not seeing that as an option, but since the audio always turns off during the lag I was thinking that could be related.


#14

I agree, this sounds massively like its audio related.
The streaming in of music probably happens in a 5-7 second loop, and it must be struggling then. The stuttering on the non-battle screens shows it absolutely is not the video card stuff, as the non battle screens are tons easier to draw.
Plus…
AN occasionalluy stutter on a new unit ( I bet it’s the first of each specific type of unit?) implies it’s hard-disk related (again, this relates to streaming music from disk).
Is there any other program accessing the disk heavily (other music streaming, defragging, a bit-torrent or other P2P program?) in the background?
Is there a comfortable amount of free space on the disk?
Is the disk perhaps quite fragmented? (contrary to popular belief, I’ve found this can make a major difference).
Disk definitely error free?

Also…

No spyware? No paranoid intenet security stuff by norton running? (anything that might be interrupting disk access, basicaly).


#15

Ok… went the extra step and updated my mobo sound drivers. That didn’t do anything either.

So the disk usages on the windows 7 resource manager isn’t really showing a high amount of reads and writes. Every now and again there’s a spike but nothing really that severe. The spikes are very brief, and don’t seem connected to the stuttering. I checked virus scanning/backups/torrents and nothing else seems to be running. I scanned my HD for errors, disk space, and checked fragmentation. Those seem fine.

The stuttering during deployment is definitely related to the first unit placement as you speculated.

*Edit: I also have the steam version of Gratuitous Space Battles which runs perfect on max settings. I’m not sure if that helps at all.


#16

Purchased through steam. Game looks as it will start then just shuts down. Never get past initial window. Here is a short video of what I am seeing: screencast.com/t/mZdWygQqbJ


#17

Games also stuttering for me and is quite unplayable right now. I sent off my dxdiag and the logs from GTB’s debug directory to cliff. Hope that helps.


#18

hmmm. as an experiment you could try renaming this folder:

\program files\steam\steamapps\common\gratuitous tank battles\data\sounds\music

to music2.
The game then won’t be able to load or stream the music. It may give an error, but it may not, and that would rule out the streaming of sound from disk as the cause. Especially strange to hear GSB works fine on the same machine. if anything, GTB is more optimised than GSB.


#19

Hi I tried this… when I did the music directory it still stuttered intermittently. I tried doing this to the entire sound directory, So sounds -> sounds2, and the stuttering stopped. I still have a bit of stuttering when I place units, but when the game actually starts there’s not any breaks.

So yeah it looks to be audio streaming related =)


#20

Interesting… I shall see if there is anything obvious that could cause it. ironically, the ONE piece of code in the entire game that is not written 100% by me is the sound library, which is commercial middleware. That’ll teach me eh?