Steam Users Problems Already - Getting Game to Work


#21

Just noticed this on the steam forums, so worth a try:


#22

I can confirm that running the game directly from its exe instead of through Steam solved my crashing problems. It might be worth stickying something about this until the Steam problems are sorted.


#23

Tried running the .exe in the location:
“Steam\SteamApps\common\Gratuitous Tank Battles” folder.

Received an error that the file “d3dx9_41.dll” was not installed. I noticed a file named “d3dx9d.dll” in the same directory as the .exe.
I simply renamed the file to the one listed as missing “d3dx9_41.dll” clicked on the .exe and it is working.


#24

Worked for me too! Awesome!


#25

I was having a problem with launching the game and only having it run in task manager with no game screen.

I eventually got it to work by making a shortcut to the EXE and running it in comparability mode.

BTW, I am running WinXP x64.


#26

I have the problem with the game not starting at all. When I try to launch it directly I get the d3dx9_41.dll error as well. I am running windows 7 64-bit. Could it be a problem with the 64 bit version of the game/steam maybe?


#27

Interesting. I have the steam version as well, but I had no problems what so ever with the game. :confused:


#28

Have you tried installing the latest DirectX? If yes and still won’t work download the dll from here dll-files.com/dllindex/dll-f … l?d3dx9_41


#29

I had the same problem, and running the .exe outside of Steam did the trick. Butter smooth now.


#30

any chance I could get you to help both me and valve work out what is causing the problem? neither of us can re-create it, so it would be really helpful if you could run a little test for us…
Thanks,


#31

Hi there. Made an account so I could post on this forum.

On-topic: Whenever I run Gratuitous Tank Battles through Steam, even with the interface off, the game gets laggy. Even more so when there are many units/turrets on the screen. This happens ONLY when i play through Steam. And the maps I unlock and items I unlock won’t even get saved when I play it without Steam. Got any ideas on what might be causing problems?

I can use any tools for diagnostics if needed.

Specs for my computer:
Intel Core Quad 2.4GHz
Windows 7 64-bit Professional
4GB RAM
NVIDIA GTS 250


#32

We are going nuts trying to work out what causes this :frowning:
I may get valve to email you about it.


#33

do you still need people to troubleshoot? I’ve been having this problem since release, and it’s really starting to bother me.


#34

Valve have already contacted 2 people, so we should get some data soon, but if not, I’ll be in touch :smiley: