Steam Workshops Weirdness


#1

Is it just me or does not all mods work to install?

I could install Posistan and LGBTQ Rights.
But subscribing to Israel (WIP) and Disaster and Emergency Situations Pack did not create any files (neither in democracy 3 or data\mods).


#2

I’m the creator of the Israel mod, and it works fine. Strange.


#3

Israel worked for me too. Have you got steam cloud enabled for your account and for democracy 3? have you clicked on refresh content on the steam workshop tab in the game?


#4

Yes i did several times. Also tried restarting game and then refreshing. Unsubbing and subbing again. :frowning: Guess i can try to unsubb, remove the .pak-files and then sub again, Then refreshing content.

Will try something like that when i get home :frowning: I wrote here mostly to see if there was anyone else having the same issue.


#5

I accidentally removed the Israel mod and now I can’t get to download again. I’m not sure what the problem is.


#6

I just found out what the issue is and how to fix it.

When you uninstall a mod via the ingame mod-browser, it removes the files but does not change/remove the record of when the mod was updated. This is probably something the developer could want to take a look at.
So if you uninstall a mod, then decide to get it (subscribing again), the game will look at the dates, see that you already have the newest version (assuming the mod-creater haven’t updated it) and not download it.

How to force-update as a user;
Browse to

C:\Users\{username}\Documents\my games\democracy3

Open mod_dates.ini (with notepad or something). It will look something like this

[mods] posistan.pak = 1383764512 despack.pak = 1383854594 lgbtqrights.pak = 1383779417 israel.pak = 1383779061

Remove either all of the rows and leave the title “[mods]” or just the one you are having issues with.

Once you’ve edited the time-stamps just open the game, go into your mod-options, the workshop-tab and click Refresh. The game will download the mod again and install it.


#7

That’s done the trick. Thanks.


#8

Your Welcome :slight_smile:


#9

Yup there was a bug in that stuff which is fixed for the next patch (1.10).


#10

Good! Cheers