Steam


#1

Now that Democracy 2 is on Steam, will existing owners get a Steam key for the game?


#2

Not sure if that’ll matter if the Steam version keeps auto-crashing every time you try to start a new game or click “how to play”


#3

Yeah, i just bought the Steam version and it keeps crashes after i click a button in the game. This is annoying. No one has figured out how to fix this?


#4

Things I have tried: updating it, reinstalling it, restarting my comp, updating my comp, checking the paths in the app, and verifying the game cache/files. I’m a little at a loss now.


#5

I tried those things as well. I emailed Steam. Doubt they ill respond anytime soon.


#6

Steam usually won’t take responsibility for their hostings/ports of “third party software” going bad :confused: They didn’t take responsibility when I had that issue with The Witcher so I had to go on forums and such and FINALLY someone had come up with a Wineskin fix that worked. If there’s a file or something that needs tweaking I’d be able to find it and fix it, but I’d have to know what the fix IS like how I managed to fix my Crusader Kings II.


#7

I too got the Steam version (for use on Mac) and am experiencing the same problem. Is there any consensus on what can be done? I just emailed Red Marble Games about a fix or getting the standalone version, but perhaps I should have contacted cliffski?

Anyway just wondering if anybody will take responsibility for this apparent problem.


#8

Got a reply from Red Marble Games. They said they are working on the problem and gave me a standalone version.
Nice guys.


#9

Well if they don’t fix it in the next few days I guess I’ll e-mail them and try to get the standalone. I have other stuff to play in the meantime so I don’t want to bug them for no reason. Nice to know they’re working on it though.


#10

AFAIK there is a fix, and we are just triple checking it works on every test machine we have before rolling it out…


#11

bought steam version and also had black screen/crash when selecting “how to play” or new game

after some google-fu i stumbled upon a solution from 2010 or something which i gave a try and it FIXED the problem for me

try this:
locate the CONFIG.MUF in your …\Steam\steamapps\common\Democracy 2\data folder
open with texteditor (eg. notepad)
change the line ForceFallback=1 to ForceFallback=0 and save the file

…also i had to change from fullscreen to windowed-mode because of weird mouse lag

now I really enjoy the game =)


#12

All mac versions bought through steam should now be working fine. Sorry about all that :smiley:


#13

Yes/no?


#14

Bravo pr0x, this appears to have worked for me as well. Thank you very much (by the way it’s 12/26/12 and this problem still exists).


#15

I tried the above, and it still doesn’t work for me. :frowning:


#16

I regocnized a further bug…maybe…
In the folder of democracy you have a debugging folder.
If I start a game with any nation and will left the game a little bit later, I get a debugging text file (debug.txt) with follwowing error message:

----DEBUG FILE----
Windows Vista detected
Error! You are using an old version of FMOD 00041601. This program requires 00042600
.
.
.
(some lines below)
.
.
.
Initialising simulation
Failed to find neuron:.\SourceCode\Neuron.cpp 176

failed to find event influence _inflation:.\SourceCode\Neuron.cpp 686

Failed to find neuron:.\SourceCode\Neuron.cpp 176

failed to find event influence _inflation:.\SourceCode\Neuron.cpp 686

The rest of this file is ok.
How ever, the game itself works very well, but this error log causes convision of thought.
Also I reinstalled this game via Steam, but same result.

Anybody an idea what is wrong or is this really not importent.


#17

Problem solved, was not caused by Steam, was caused by Mod “Inflation”