stuck on start screen


#1

I’m using version “Full 1.60” from Humble Indie Bundle #6.

In prefs.ini I changed “windowed = 1” to “windowed = 0” because the game wouldn’t work in full screen mode (my monitor gave an out of range error message)

Now, when I start the game, I get a window with a background image, a clickable “gratious tank battle” banner, the version number in the upper right corner and background music. I’ve attached the screenshot (downsized) below.

What do I do now? Shouldn’t there be some kind of menu?
(I tried both randomly clicking in the window and pressing random keys on the keyboard – nothing happens, with the exception of ESC which allows me to quit the game)

prefs.ini:[prefs] width = 1280 height = 1024 windowed = 1 sound_channels = 512
debug.txt:[code]----DEBUG FILE----
Windows XP detected
GSB Debug File. App version Full 1.60
Desktop resolution is 1280 x 1024
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
GBufferedFile failed to open file
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine
GBufferedFile failed to open file
releasing D3D engine
D3D released
END DEBUG—[/code]
drawdebug.txt:Initialising 3D Engine in windowed mode Driver : ati2dvag.dll Description : ATI Radeon X1200 Series DeviceName : \\.\DISPLAY1 Checking For Shader Support hal_caps.D3DPTEXTURECAPS_POW2 is true NumSimultaneousRTs:4 hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0) About to Create 3D Device with width: 1280 and height : 1024 Attempting hardware Vertex Processing Finished initialising 3D Engine Initialising Render target of 512 X 512 rt_ship rt_ship Initialising Render target of 2048 X 1024 rt_offscreen1 rt_offscreen1 Initialising Render target of 2048 X 1024 rt_offscreen2 rt_offscreen2 Initialising Render target of 2048 X 1024 rt_transition rt_transition Initialising Render target of 2048 X 1024 rt_distortion rt_distortion Initialising Render target of 2048 X 1024 rt_selection rt_selection titlescreen2048.bmp cwfont20.dds zekton16.dds debris.dds contrails.dds escapepod.dds escapepodengines.dds shield_impact.dds client_interlace.dds dialog_client.dds 19px_highlight.dds 19px_highlight_black.dds smokeclouds.dds runninglight.dds shield_collapse.dds border_depth.dds box_background.jpg textbutton.dds textbutton_h.dds teaser.bmp circular_wipe.dds dialog_titlebar.dds button_close.dds button_close_h.dds Deleting texture: rt_ship Deleting texture: rt_offscreen1 Deleting texture: rt_offscreen2 Deleting texture: rt_transition Deleting texture: rt_distortion Deleting texture: rt_selection Deleting texture: titlescreen2048.bmp Deleting texture: cwfont20.dds Deleting texture: zekton16.dds Deleting texture: debris.dds Deleting texture: contrails.dds Deleting texture: escapepod.dds Deleting texture: escapepodengines.dds Deleting texture: shield_impact.dds Deleting texture: client_interlace.dds Deleting texture: dialog_client.dds Deleting texture: 19px_highlight.dds Deleting texture: 19px_highlight_black.dds Deleting texture: smokeclouds.dds Deleting texture: runninglight.dds Deleting texture: shield_collapse.dds Deleting texture: border_depth.dds Deleting texture: box_background.jpg Deleting texture: textbutton.dds Deleting texture: textbutton_h.dds Deleting texture: teaser.bmp Deleting texture: circular_wipe.dds Deleting texture: dialog_titlebar.dds Deleting texture: button_close.dds Deleting texture: button_close_h.dds



#2

Greetings itsme and welcome to the forums.

Yes you are right there is suppose to be a menu and it is just of the bottom of your screen.
My suggestion would be to change the prefs.ini to this:

[prefs] width = 1024 height = 768 windowed = 1 sound_channels = 512

Then run the game again. you should be able to see the menu bar.
From there you can select options and see the resolutions avaliable for the game.


#3

That worked. Thank you very much!
I use width=1280/height=960/windowed=1 now on a 1280x1024 desktop.

Interestingly the full screen mode works with height=960 as well (not 100%, there are still some synchronisation issues, but more or less).