Switching from Full Screen to Windowed Mode Doesn't Work

Tried going into options, unclicking the Full Screen Checkbox and hitting Apply Changes. The game reboots back in Full Screen and doesn’t seem to work at all.