Tax Bug?


#1

I’m playing a game where the Income Tax suddenly stopped generating any revenue. It was set at “Reasonable”, and had been for awhile, but the area on the Income Tax screen that usually lists the amount was blank and it didn’t show up on the pie graph. The drop wasn’t helping my budget, so I tracked the problem down to Income Tax.

I saved the game and reloaded and Income Tax was back on and listed at 52 Billion/Month(!). I think I’d had the same problem in previous game, but wasn’t really sure how everything worked at the time.

This is the full version 1.01.


#2

Playing around with it some more, it’s not limited to Income Tax. This time when it happened, Sales Tax disappeared. Like Income Tax the last time, it didn’t appear on the pie chart and no revenue was listed on the Sales Tax screen.

I went to Options to save it so I could reload, but for some reason Options exited the game completely. There was no Save button and no Return to Game. I loaded and old game and selected Options, and again, it exited completely with no Save or Return buttons. I shut down D2, started it up again, loaded a different game, hit Options, and it exited completely again.


#3

This sounds very bizarre. Is this the case even with a new game? Ie, if you start up D2, start a new game, then go to options, you have no choice of resuming the game or saving?


#4

I’ve tried to nail it down, but it seems to be random. After that last weird glitch with it, I started another game and got assassinated in my second term. When I got to the main menu, I immediately started up another game, checked Options, and suddenly the Save & Resume buttons were back. I reloaded that old game where they had disappeared and the Save and Resume buttons were back there as well.

When I got up this morning I started a new game. I thought the bug might have something to do with minimizing (which I’d done a lot of), so I didn’t do any of that. In fact, I was so paranoid I’d lose my progress that I didn’t try to save or minimize it at all. I made it through about five terms and had all but two of the special accomplishments, but I had to leave so I finally clicked Options to save it. The Save & Resume buttons were gone again. :frowning:


#5

hmmm. i wonder if it’s a multiple-terms related bug. Don’t forget the game autosaves, and you can always use that in the short term if this befalls you again! I will try and work out what causes it.


#6

Actually, for some reason autosave isn’t working either. It autosaved once in my first game and either won’t do it again or it won’t overwirite the old file. I do have the option checked, so I’m not sure what’s up with that.

I’m also getting crashes about 1/3 of the time I try to start a new game. I’m going to reinstall and see if that does anything.


#7

I’ve not started that many new games on Democracy 2, but I also had a crash when I tried to start one the other day (on the new patched version).


#8

I just reinstalled and got a crash right away when starting a new game, so there’s got to be a bug in there somewhere. These crashes happen during the “Loading x…” process.

On the tax issue, there is definitely something fishy going on. I was just playing a Gaia game and my income kept shrinking and there was nothing I could really do to stop it. It dropped from over 12 billion to under 8 over several turns, and no taxes or tweaks seemed to have much of an effect. I saved and reloaded, and the next turn my tax revenue shot up to about 27 billion.


#9

weird. One thing people may not be aware of is that the chancellors efficiency will affect how much tax you raise. A high efficiency chancellor is going to raise more tax, so that’s worth taking into account. If you have a game where you think something weird is going on, its best to send me the save game and I can load it in a debugger and see where the numbers are coming from.


#10

I’ve also had the problem where going out to the options screen to save and quit does not give me the option to Resume or Save a game. It’s my first game, which I successfully saved last night (at 1am!) and then resumed this morning but I had no Save/Resume options when I finished today. I’ve not reached any elections yet, if that’s relevant.


#11

that’s very helpful, cheers. I’m trying to reproduce this right now.


#12

BWAHAHAHAHAH!!!

Found it I think.

this only happens if you started the game, and then loaded in an old game doesn’t it?

I’ll get it fixed for the next patch.


#13

I emailed you the save where revenue jumps from 7.85 billion to over 28 billion. My Chancellor was very experienced (I think he’s maxed out), so that’s not it. It was really frustrating because you don’t have a lot of debt maneuver room in the Gaia start.

I hadn’t introduced new taxes or tweaked anything that turn, certainly not enough to compensate for a 20+ billion increase. Like I said, revenue gradually dropped from over 12 billion to where it is in the save.


#14

Thanks, looking at it now. I have my suspicions that Im failing to save the income multiplier data which takes into account stuff like tax evasion. It might be that… but I’m still investigating…

EDIT: Yes that does seem to be it. Damn. nightmare recursive code hell… will take a while to sort that… But definitely to be fixed in the next patch…