That was Campaign?


#1

So I finally finished campaign and I wonder if I was playing on the easy mode or something.

Almost every fleet I encountered was a single lone ship. Sometimes, I would GASP encounter a total of TWO ships and rarely would I encounter a ship or two with FIGHTERS!

Is there something I missing?


#2

Interesting…

I ran all kinds of fleets one such is a dozen alliance cruisers with such thick armor it barely move.
Then i ran into a swarm of fighters with a one hand countable number of frigates.

Suggest checking your INTERNET connection


#3

I don’t know if my internet connection is eating ships or not…


#4

I too encountered this very same thing. When I first started playing the Galactic Conquest campaign, I got stomped and stomped hard. I’d frequently encounter fleets either larger than the one I was currently fielding, or with just the right combined arms to dismantle my fleet even if it was larger. Now, it’s just single ships, rarely with accompanying escorts.

I’m playing the STEAM version of the core game, with the direct download of GalConq, if that makes any difference.


#5

I’m getting this as well. 1 maybe 2 ships facing my 35,000 point fleets.I posted about it in the support forum but got no replies. Oddly everything worked fine before the last update. I’m using the steam pack that had the core game, tribe,swarm,and the order, with nomads,and galactic conquest bought from here.


#6

Maybe everyone is using one ship scout fleets or something…


#7

Whee, another tactic i posted first xD

Anyway: I really think there should be a mechanic that puts a lower limit on size allowed. Maybe pick base defense fleets over 7k HP?


#8

I am still getting “normal” fleets to oppose me (i.e. 70,000 HP vs. my 20,000). I may start a new campaign just to see if I experience what you all are describing. It would be Nirvana.


#9

I had the same thing once (difficulty “Hard”). After deleting that campaign and starting a new one (“Medium”) I did not experience that problem anymore. I have bought my version through Impulse.


#10

I can see how unbeatable fleets would be a drag, as mentioned elsewhere, but not nearly so much as the 1-2 frigate fleets I have been facing in all my campaign battles so far. I have tried switching difficulty levels and species groups, but after a good 10-15 campaign starts, the battles remain ones that my three-year old can win… and has. Is there a way to filter out tiny fleets from being dealt over the webs?

The worst part of these tiny fleets is that there is never anything to capture! I was so psyched for that part.

T.


#11

Is this not seen as a problem? Is it somehow the user’s fault? Is there just not any solution?


#12

All better now. Huzzah!


#13

I’m glad that it all worked-out correctly in the end. Enjoy the game! :slight_smile:


#14

Thank you your grace. Nice… er… Avatar. I would love to play a Starblazers version…


#15

What was the fix? Please explain. Have the same problem here.

Thanks.


#16

I can tell you what I did, Rabban. I am not sure which of these things, if any of them, made the difference.

When I was having trouble with small fleets, I had the original aliens, plus the Tribe, Swarm, and Order packs. I didn’t have the Nomads. Finally I caved into pressure from my sons and ordered them. As with my last upgrade of GSB, when I went to install, everything stopped working. I wrote to Red Marble, and they had me scrap the old game, download a new complete version, and delete my file of old ship designs and achievements (Library>Application Support>.com.redmarble.GSB). When everthing was running again, I noticed I had a new version number: 1.55.3. After playing the original game for a little while (to get enough honor to re-purchase critical modules), I went to try campaign again. Because I had a new program, I had to re-register it, and choose a new screen/user name (Lord Greenwood, if anyone cares).

So is it having all four extra races? is it the newer version number? Is it the new username? Something else? I have no idea. But it worked. Campaign is now incredibly difficult.


#17

Thanks. My story is somewhat similar. did Tribe, swarm, Order, Nomads, THEN Campaign. Nothing but errors. Contacted Red Marble – scrap game and download complete new with races I had purchased… Worked like a charm. Very difficult campaigns. Then updated software and . . . tiny fleets. I am running “full 1.56.0”. Been dealing with it for a couple of months, foolishly thinking that it was a function of the new version not having enough new version fleets to pull off the internet, and that it was only a matter of time until the competition increased. The started lurking here hoping for an answer. It is frustrating because it is a great game, wish I had the difficult campaigns again.